MobileSheets Forums

Full Version: Can't connect to Companion
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi there

I don't appear to be able to connect to the companion any more. It was working fine but I don't even get the pop-up any more. I temporarily disabled my firewall for my Home network to see if that helped, but still nothing. I've got a Galaxy Note connecting to a windows 7 PC. Any suggestions gratefully received!

Thank you
I'm working on a fix for all the connectivity issues today. Included with the fix will be a way to manually type in the IP address for the tablet in the companion app, and initiate a connection that way. I'm also going to try to provide advanced options to specify what ports/ip addresses to use as this may help some users. Thanks for your patience.
I too am having connection problems. I was getting crashes immediately after opening up and going to a set list. I reinstalled my Amazon copy and re imported all my song pdfs. Now I can't connect to the companion except manually. I have not knowingly changed any settings. It used to pop up a device and ip in the companion window. Now I have to got connect>manual and type in the IP which appears in the tablet app. How do I get back to how it was before?
Very little changed with the new version as far as the connection goes, except for the handling of the broadcast address. I believe this is where the issue is. Do you have your PC hooked up to a wired router, and then a wireless router hooked up to the wired router? Another user has problems with this, and hooked everything into just one router and the connection started working. With the next version, I will revert to how I handled broadcast addresses before, but I think I will need to do more investigation to see where the connection is failing when multiple routers are involved. It could be that multiple subnets are involved, which causes the packets not to be forwarded between them.
I have a router which connects wirelessly with the android tablet. The PC running the Companion is connected via cables and through a Netgear switch to the router.

I'm currently connecting manually to the tablet every time. The Companion doesn't even remember the last IP address I used from session to session. It always reverts to
I have not fixed the companion app so that it saves the manual connection IP address yes. Sorry about that.
Any progress on the automatic connection? I'm still having to do a manual connection (Thanks for fixing the companion so it remembers the last IP of the tablet.)
I fixed everything related to connections in one of the previous updates. It now operates the same way it used to. If you are still experiencing issues with v4.0.8, then something else must be going on...
I'm still experiencing the same problem I described recently. Ie, can't connect to the companion either automatically or manually. Sad Looking forward to cabled connection!
(03-22-2013, 02:10 PM)Zuberman Wrote: [ -> ]I fixed everything related to connections in one of the previous updates. It now operates the same way it used to. If you are still experiencing issues with v4.0.8, then something else must be going on...
Well I've tried turning the WI-Fi on and off before and after starting the Companion but I never get the pop-up window any more. I did use to work and I can still connect manually, so, I can't see there's anything wrong with my ports, firewall, etc.
If you can suggest any further tests then I'll gladly report back.
I'm looking forward to it too, but my day job isn't giving me much time I'm afraid.
I cannot connect my Windows 7 PC to my Samsung Galaxy 2 tablet using MobileSheets Companion. It won't connect automatically, and it won't connect manually. If I look at the packets between my PC and tablet using Wireshark, I see that the tablet is sending TCP resets for port 16569, so that tablet appears to be rejecting the TCP connection request. Turning off my firewall has no effect. Any ideas what can be going wrong? Is there any way I can connect using USB instead?
Usually the only thing that I have to do to fix any connection issues is turn the tablet wifi off, then back on again. If you are seeing the popup window to connect, the code past that point is really simple. I just call into a socket library to connect. Some people have more complex networking setups which can cause issues.

I am going to work on seeing if I can add USB support, but I don't think it's going to be simple. I basically will have to trick the tablet into thinking the Companion App is a USB accessory so that it will allow data to be sent back and forth. There is some sample code out there for this, but I don't think it will be easy.
I don't have a complex network setup. I just have a wireless router. I tried turning the tablet Wi-Fi off and on, and I'm not seeing anything pop up on Companion. I tried connecting manually again, and I'm seeing the same problem.

Question 1: Should MobileSheet be running on the tablet when I'm running Companion? I've tried it both ways, and I get the same results.

Question 2: When I get the failure, it says that maybe I should try different ports. Are there any other TCP ports that Companion could possibly be using?

Question 3: How does Companion detect the presence of a tablet?
Simple question - Are you tapping the computer button at the top right of the library screen to start the sync? The tablet should go to a black screen that says "Waiting for connection to PC". This is what starts the connection process (the tablet will start putting out a broadcast message letting the PC know of its presence).
Pages: 1 2