MobileSheets Forums

Full Version: files invisible via MTP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I connect my tablet and my laptop with a USB cable MTP (media transfer protocol) is used. When I navigate on the laptop to the MSP directory
the files mobilesheets.db and mobilesheets.db-journal are not shown. Other files in the same folder are displayed as expected.
The same happens with the backup directories. The .msb backup files created by MSP are not visible on the laptop. Files that I copy with a file manager on the tablet to those directories are visible. Both the copies of mobilesheets.db and mobilesheets.db-journal that I create in the backup directory and copies of the .msb file that I create somewhere else are visible.
Any idea what's going on here? Different access rights? Some special magic with Android and MSP?
I often run into issues with files not being visible through MTP. I always have to disconnect my tablet and plug it back in for some files to show up after they've been created or modified. I've recently starting using the ES File Explorer LAN option to have the tablet copy files either directly to my PC or to my shared network storage instead of my PC trying to pull the files. This approach never fails for me.
I'm doing the same with ES Explorer. Fine piece of software even if it had some bad press lately.
Another good option is Solid Explorer. I'm not sure which I like more yet.
I also did like ES Explorer very much, but recently it started suggesting services that I do not want, insists on scanning storage and apps, and so on.

I tried Solid Explorer but it needs some time to get used to. Then it expired before I could make up my mind.
Thank you for all your proposals. I have alternatives enough to do all I need:
1.) TotalCommander for Android with its plugin TotalCmd-LAN on the tablet to access shared folders in the local WLAN via SMB
2.) FolderSync to synchronize folders on the tablet with folders in the local WLAN (SMB again)
Both is pretty slow when I need to copy my 800+ MB backup files from the tablet to the PC. So for that I use
3.) MyPhoneExplorer's file transfer via USB cable. It is installed on the PC and uses ADB (Android Debug Bridge), so installing an ADB driver on the PC and activating USB-Debugging in the developer options of the tablet is required.
4.) My tablet supports USB OTG so I can plug a USB stick into an adapter and copy files to and from it. Not what I use every day, but helpful in certain cases.

What I am looking for is a better understanding of MTP. This is what today's tablets and PCs pretend to support out of the box without any further apps and installations. Thank you for the hint: after restarting tablet and PC all the files are visible. WTF is going on here?

In the good old days of prehistoric Android 2.x USB mass storage (UMS) was common. I could plug a phone into a USB socket and it worked. Recently a friend asked me how he could transfer his scores to the tablet and I had to answer "without a thourough investigation of your Android version, your local network, the brand of your tablet and several other facts I can't tell for sure, probably you'll have to search and install additional apps"
The problem with 'prehistoric Android 2.x USB mass storage' is that effectively two independent computer systems (Android and PC) had a simultaneous mount of the same physical filesystem, with relatively high risks of corruption. MTP is a bit limited, but designed for concurrent access.
Really? My understanding was that connecting via UMS unmounted the SDcard from Android. That's the reason why apps that are moved to external SDCard don't work as long as the phone is UMS connected to a PC
I recall it had something to do with concurrent acces, so you could be right. Anyway, UMS was considered to have serious disadvantages.

EDIT: This article explains a lot: