MobileSheets Forums

Full Version: Cannot Connect to Companion
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Now it won't connect.  I get error message.

Everything had been working perfectly.  I wonder if the latest change in the Companion did something.

I have not added any firewall or made any changes on my end (a far as I know).

I just restarted the router and will try again.

Hmm, sounds like the same thing I reported here -
I can revert the changes then, as they obviously haven't helped those with connection issues. I have no idea why it wouldn't work for you guys though...
Re-booting the router seems to have fixed it.

Sorry for the false alarm (and thank you for the quick response).

But, now it is not connecting on my other tablet. Maybe it changed the default IP address?
Try turning wifi off and then back on for that tablet. If that doesn't fix it (and you weren't having problems before), I'll just push out an update that reverts the changes.
Interesting. This time it did not connect because the tablet tried to use a different wifi network. I have no idea why it did that.

So, I reverted back to the correct wifi network, re-started the router and it worked.

I have no idea what role, if any, MS or the Companion might have had. But, I don't recall it happening before. (On the other hand, I would not discount user error on my part).

So, now it worked. Hopefully it will be smooth sailing from now on.Smile

I've re-booted the router - even changed it for another - switched the tablets off and on again and also turned off the wi-fi and on again, re-booted the PC, checked the IP address is correct and it still doesn't connect for me.

Whilst I have resigned myself to a manual connection (for some un-resolved reason) I've always been able to connect. I have never been unable to back-up to the PC and it's a bit of a concern for me. I have a back-up on the tablets, but that's hardly what I would call a solution.

Whatever it is, has to be related to either the latest upgrades for MSP and Companion. My money is on the latter, but that's purely a hunch.
(10-02-2016, 02:18 AM)GraemeJ Wrote: [ -> ]Hmm, sounds like the same thing I reported here -

I am having the same problem with Mobilesheets version 3.6.9 and companion version 3.1.9. It says" You appear to beconnecting to an outdated version of companion"
Version 3.7.0 is the latest version and it is available on all platforms now.

Hey, folks. Call me Joe Btfsplk if you want. I feel jinxed. Whenever I march on to something I haven't used before I seem to run into stuff that makes no sense at all. I cannot get Companion to connect to my MobileSheets Chromebook across the room and the advice I read hasn't helped so far.

My network isn't wildly exotic. The whole house is served by a Ubiquiti router with one local subnet, 192.168.2.*. The wireless part connects to a Netgear mesh router that is configured as an access point so that all DHCP requests are handled by the Ubiquiti router. My PC has been served address and the Chromebook has

Yet the sticking point appears to me to be that the Chromebook on selecting "Connect to Companion" shows address with nothing like guidance anywhere that that is something that can be configured. My Certified Netware Engineer certificate from 1992 means nothing anymore, but it's a badge to prove I once did some deep diving in networks and I can't recall any precedent that could explain how and why something like that should pop up when everything else around here is happily communicating on our single subnet.

Once again, I'm at your mercy. Help!
Hello Steve,

You can't currently rely on the automatic connection with a Chromebook, as ChromeOS places all Android applications behind a firewall (hence why you are seeing a different IP address in MobileSheets). There is no way for MobileSheets to know it's behind that firewall. The long term solution for this is I'm going to add support for DNS-SD, but I haven't had a chance yet to add the necessary changes for that. In the meantime, what you'll need to do is click the Connection dropdown in the companion app, then "Manual WiFi Connect", and enter That should initiate the connection and then you should be able to proceed. If you encounter a connection error after doing that, then something is blocking the TCP traffic between the two applications (mesh routers can potentially cause a lot of headaches by not forwarding traffic between devices).

Thanks, Mike. I had tried the manual connect and didn't succeed in a couple of tries and gave up trying pending further advice because I was guessing the order to do things and the IP address to enter. Yes, now when I say connect to companion on the perverse Chromebook, come back here to my PC, enter the real IP address. and manual connect, it works just fine. Things are going fast around here ATM. I just got a new (to me, i.e., refurb) iPad Pro, a new Apple Pencil, and bought into the iOS version of MobileSheets. Glory be! That setup works exactly as the manual says it should. I had been resisting Apple ever since I bought and disdained an Apple ][e in 1981, but I had an operation to allow me to attach a BAHA (bone-anchored hearing aid) behind my left ear and found that the Android app that supports it was so dumbed-down I'd prefer to just call it broken.

With so much invested in my hearing, the humiliation of converting to an iPhone was a no-brainer.

In for a penny, in for a pound. Apple sure invests a lot in making sure all their toys play well together, so adding an iPad, too, was easy to justify, especially since it's been the standard for almost all the pro musicians around me.
I'm glad to hear you got it all set up on the iPad, and you were able to get the companion app connected to your Chromebook as well. I hope things are overall a little smoother with the iPad.