MobileSheets Forums

Full Version: External Card
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My new 13" tablet arrived today (Colorfly CT132) and I've had a great time exploring it and the latest version of MS. By and large, everything works as I would expect.

I have one problem - no matter what I try, I can't get MS to write the files to the external SD card. I can see the card in the file manager and I can point MS to the card, but it stubbornly refuses to write any data to that card. MS works fine if I use the internal storage.

I rather suspect this is problem that's more to do with the OS (Android 4.1.1) than MS, but I don't have a clue where to go from here?

Any clues will be gratefully received Smile .
I have the same problem. (I gave up and have just backed up on the internal card).
It's an Android OS limitation as of Ice Cream Sandwich. For example, this is how Samsung replied to one customer:

"Thank you for contacting Samsung Customer Support.

I’m sorry you are having issues moving your apps to SD card. I can understand your frustration as it is good fro freeing up memory on the tablet.

Please note that moving or installing apps to external storage is no longer available on any Android from version 4.0 and above, due to how the Android operating system reads storage on our devices.

The Android OS now operates on a unified storage system from Ice Cream Sandwich onward, meaning it will read one data partition for storage, rather than two.

The reason why previous Android versions had the capability of moving apps to external storage was because the phones memory was split into two partitions, one for external storage and one for internal.

Now, with Android using a unified storage system, all applications will be stored completely on the internal memory of the phone. This allows for around 11GB of storage space on a 16GB device for apps. Google, the developer of Android, feels this is more than enough for users, as their operating system was designed for use on their own phones as well, which do not have any external storage at all.

Please also note that we do not advertise any of our devices as having the capability of running or installing apps directly onto the external memory card. You will have to install your apps to the internal memory, but anything else (music, videos, documents etc.) can be stored on your external memory card. "

Google wants the OS to work the same for phones as it does for tablets. They also want to drive users to use their cloud storage. Unless you root your device, the removable SD card is pretty much useless with ICS.
Just to clarify, Google also made it so applications are no longer given access to write to the external SD card. That's why MobileSheets can't write to your removable storage. Having said that, you should be able to put PDFs/backups, etc on the card for reading purposes.

It seems we're not alone! A net search found plenty of people reporting the same sort of problem.

One person said this;

After upgrade to Jelly Bean I noticed that I wasn't able write to sd card. In ICS and GB everything was fine. After dipper digging I found it's a bug with permissions.

To fix problem you need ROOT (check another thread in this forum).

Edit file /system/etc/permissions/platform.xml

Find text

<permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
<group gid="sdcard_rw" />
And replace it with

<permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
<group gid="sdcard_rw" />
<group gid="media_rw" />

Make it with caution. XMLs are very syntax sensitive. Any mistake may make your tablet inoperable.


I found this interesting, but I don't know enough about the Android OS to understand half of it - I couldn't even find the file concerned. I assume it's hidden in some way, but I don't know how one gets to see it. If someone here does know, perhaps they would be good enough to explain how one does all this stuff?

I have a 32 GB card just pining for some data Smile .
I have to say this all seems pretty stupid to me and it's going to lead to a lot of confusion and annoyance for anyone who buys one of these things. I think that *every* specification I have read for a tablet (and I've read a lot of them lately) touts the fact that the device can use external storage - yet it would seem that this is totally untrue.

I read the reply from Samsung, but even that doesn't apply in my case. I can't write data, of any description, to my external card!!
It's now 4:40 am and I have a rehearsal tomorrow - but I've done it!! Read and write to the SD card has been achieved. You have no idea how pleased I am with myself Wink .

Basically, I followed the route (and used the tools) shown in this post - - and rather to my surprise, it worked.

I can't guarantee it will work for others, but it's worth a try.
Awesome work Graeme. For those of you with rooted devices, this should work for you.
Just as an update to this post, I went ahead and got a Samsung Galaxy 2 10.1 tablet just so I could test using external SD cards (it's running 4.2.2). I had absolutely no problems reading from or writing to the external SD card. So I'm not really sure what to believe anymore...

(09-16-2013, 05:34 PM)Zuberman Wrote: [ -> ]So I'm not really sure what to believe anymore...

I've had similar feelings about computers ever since my first one (and that was a KIM-1). Whoever it was that said these things were logical was feeding us a big lie Smile .

My tablet is running 4.1.1 - maybe they saw the light and changed something?
Cheers Graeme, worked for me. I couldn't figure out what was wrong with this thing for a while.
Another satisfied customer- Pleased it solved a problem for you.
OK bizarro world now. I went to backup and it won't let me again, same error message. I went to ES File explorer to the edited .XML. Now it's no longer edited and when I try to edit it, it won't allow me to save. Don't see the .BAK file either. It's as if I had never done it, and am not allowed to. Any thoughts?

UPDATE-downloaded Root Explorer and was able to edit in there again. It still works after reboot, we'll see I guess.
(09-16-2013, 05:34 PM)Zuberman Wrote: [ -> ]Just as an update to this post, I went ahead and got a Samsung Galaxy 2 10.1 tablet just so I could test using external SD cards (it's running 4.2.2). I had absolutely no problems reading from or writing to the external SD card. So I'm not really sure what to believe anymore...


I have a Samsung Galaxy Tab4 running 4.4.2 and would like to know what settings I should make in MobileSheets to try to get it to write to my external card also.  I had made a post yesterday about not being able to write to the external card and just want to make sure that I have attempted it with all the proper settings before I give up.


Windows 7 home edition - Companion version 1.5.6, MobileSheets version 4.1.6 on Samsung Galaxy Tab4 running 4.4.2
I responded to your post here:

Sorry for the delay.