MobileSheets Forums

Full Version: Beta testers needed for new annotations functionality
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
I'm getting info there is update available, current version 0, update version 1, but when I download and install the update, the message reapears. |'ve also tried to download new appxbundle from the link you've sent, uninstall current beta and install new one, but still the same.

Any thoughts?
(09-27-2020, 03:20 PM)NeoCZ Wrote: [ -> ]I'm getting info there is update available, current version 0, update version 1, but when I download and install the update, the message reapears. |'ve also tried to download new appxbundle from the link you've sent, uninstall current beta and install new one, but still the same.

Any thoughts?

I do not receive a update reminder however I did download a new version from the link and it now says 2.9.8. Bookmarks now work fine but crashes are still happening for me. I have a complete fresh database now with a blank page created within mobilesheets. It happens after a while when annotating both with stylus and finger.
Yes, version is 2.9.8. After restart I don't get update reminder anymore (don't know if it's connected).
First look at the new annotations.
Up 'til now I am just trying to see how the radial menus work, I have not tried to use layers for example.
My comments at this point (Win10):
- With the toolbar closed, how do I leave annotation mode using only the radial menu ?
- How does one use the pan icons from the radial menu or toolbar?
-- If I select pan I can not select something to move
-- If I select something the actions toolbar shows up and I can select pan there.
-- If I select something and then click on pan in the radial or toolbar menus the something is unselected.
If you ask me pan can be removed from the radial menu and toolbar as it does nothing, or am I missing something?

I find that the select tool is way too hidden, especially as it is needed to nudge stamps. I need to nudge my stamps just about every time. It should be at the top level or at least in the individual tool menues.

I am seeing random crashes when doing things in the radial menu. I have never been able to recreate a crash.

Overall I see this as a big improvement that will make annotation much quicker once the bugs are out Smile
Because I use Surface Pro 5 and have Surface Pen, I've focused on using it to annotate blank page. Few bugs already found (using default app/annotation settings):

1. Using eraser crashes MS almost every.
2. Dashed lines are shown as dashed while making them but they are't dashed anymore after the line is done.

I really like pressure support, stylus mode and ability to leave it automatically if no input, stylus button tool selection. You did great job, Mike.
I've installed the latest (2.9.8) and imported my library, and I've seen a couple of issues already:
- Several sheets that already had annotations from the release version show the annotations, but the positioning is a bit off. From your description of the new system, maybe this is to be expected.
- One sheet with previous annotations I try to open gets stuck on the loading screen (balls rolling in a circle). I can press escape to cancel and get back to the library. When I load a setlist with that piece in it and advance far enough, it says the pdf does not exist. Maybe the import messed up some folder locations.
- When trying to use the annotate tool (just with a mouse, no stylus yet), MS crashes after a few operations. It seems several different operations cause crashes: selecting different tabs in the stamp menu, erasing things, selecting things, etc. I can test this more specifically to get specific repro steps if that would be helpful.
- Is there a write-up of the new annotations functionality? There are some things I'm not clear on, and the manual only seems to show the old functionality.
(09-28-2020, 01:20 AM)MartinH Wrote: [ -> ]- Is there a write-up of the new annotations functionality? There are some things I'm not clear on, and the manual only seems to show the old functionality.
Look in the first post of this thread. The link is there.
Don't know if this is bug or intended behaviour - If I make Crescendo or Decrescendo and I try to make bigger (longer) one using my pen, I see only small one while making it that doesn't change it's size and desired size is shown only after I release the pen from my Surface. Other shapes (arrow, line, etc.) don't show this behaviour and scale properly while making them.
NeoCZ - I forgot to bump the version number in the code itself, so it caused a cycle where the app would update but think there was still a newer update available. I changed the latest build number on the server back to 0 because of that (which is why you saw the problem go away), but the next update will increase it to 1. As far as the crash with the eraser, I haven't received any crash reports related to the eraser, so that's quite odd. Do you have internet active on the device? There is a separate bug that I just fixed that could crash at any point after using one of the dropdowns (or even the edit popup), so that may make it difficult to pinpoint what is causing certain crashes. I can't seem to reproduce the issue with the dashed line either. If that setting is checked, I'm always seeing a dashed line. If you toggle it off and on, do you still see the same behavior? As far as the crescendo/decrescendo, if you want to resize them, it's a two part process. 1) Press down and drag to where you want to start the crescendo/decrescendo. Wait for a half second or so (with your finger still pressed) and then drag to where you want the crescendo/decrescendo to end. I designed it this way so that it's easy to position it initially, but then resize it without requiring a second action. If I implemented it like an arrow or line, it would be harder to get the initial placement right. If users don't like this and would prefer to have it work like other shapes, meaning you press and drag to size it, but then have to use the nudge tool or drag to reposition it, I'm fine with making that change.

Cmart - I'm guessing those crashes are caused by a complicated issue when it comes to freeing resources used in the dropdown/popup windows. There were a few things I wasn't cleaning up correctly, so I left it up to the garbage collector which can run at any time, and it caused a crash in the cleanup code. This makes it completely random when the crash can occur. I never saw this crash while testing because the garbage collector never ran for me during the tests (probably because my development PC has a lot of RAM).

DonC - You can't leave annotation mode using the radial menu at the moment. You would need to either tap the back button on the device, or tap the "X" at the top left. Even with the toolbar collapsed, that X is always present. There really isn't any room in the radial menu for an exit option at the moment, but I could move the Snipping Tool under "Other Tools" and then put an exit option where the snipping tool was under "More". As far as the panning tool, that is for panning the page (moving it around). If you've zoomed in a lot, the panning tool will let you move around the page with your finger. If you use a smart stylus, then the panning tool isn't really needed if you enable stylus mode, because then you can already pan with your finger. You have multiple ways you can quickly access the select tool: 1) The toolbar, 2) the radial menu, 3) The command bar, and 4) The side stylus button if you configure that under the settings. The two finger tap currently switches between the current tool and panning, but if users prefer, I can make that customizable so it could be used to toggle between the current tool and selection, or any other tool. As a side note, if you select something with the select tool, you can also drag it to reposition it, or just use the nudge tool as you are aware. I do realize that it takes more work to select things now than in the old version, but now it's much quicker to create annotations in rapid succession, which was painful with the old design. Especially if users are using a stylus, you won't need to select and nudge things into place, as you can accurately place things. If you would like, I could also add an option that automatically switches to the selection mode after an annotation is created and selects that new annotation. That would mimic the old design, but would probably get really annoying while using certain tools.

MartinH - It is unfortunate, but yes, the positioning of some annotations may be off after updating. This is necessary for moving to the new design though, and the changes in the new design ensure that annotations will be positioned correctly when mixing Android and Windows 10. I also received reports of annotations shifting in the old design for some users on Windows 10, so the update should address that too, as all coordinates are now saved relative to the underlying document's coordinate system. Can you long press the song that isn't loading on the library screen, tap Share->Export as .msf and send me the .msf file? I'd love to test that out and see what's failing. I think the crashes you are seeing are due to what I described above with the garbage collection. As far as documentation, I'm going to be working on update the manual once I've finished the changes for the companion app and the e-ink version. There is no documentation available at the moment, so if you would like explanations on anything, please ask and I'll be happy to provide that.

Thanks everyone,
Yes, internet is active, is there any way I can check crash reports are made? Are they stored somewhere in MS folder? 

I make crescendo this way - select it from radial menu, draw a line using a pen from where I want it to start to point where I want it to end.

Don't know why you don't see dashed line bug. I just create new placeholder (blank song), open it, set pen to dashed and see bug described above. I also tried it with regular PDF and it's the same. The same applies to eraser bug.

EDIT: Just sent you PM with link to video showing those bugs...
I've changed the crescendo/decrescendo behavior so you place and size immediately. Let me know if you like that better. As far as the dashed line issue, when I saw "line", I switched to using the line tool. I didn't realize you just meant drawing with the pen tool. I've fixed that issue now. I'm still not seeing the eraser issue, but I'll continue testing. As a side note, if you tap the eraser tool in the toolbar to see the settings (or use the radial menu to go into the eraser settings by tapping the arrow at the edge), you can change to a different eraser mode. If you wanted to delete lots of stuff at once, using the drag mode is more efficient, as it will delete the entire annotation at once if you drag over it and release.

Yes, I know about different erase modes, this was just for testing purposes :-) Also if I change erase mode to Draw box, app still crashes. Tap mode seems to be OK.
I just pushed out a new update, so if you start up MobileSheets, you should see a notification about a new update being available.

Good, the crash when using the eraser looks to be gone.
I have been trying the favorites.
What I see is that it is necessary to make 1 click more on the page in comparison to using the tool directly.
For example: using the stamp tool directly, the first click makes the first stamp.
Using the stamp tool through the favorites the first stamp is after the second click on the page.
The same using crescendo, etc.
The favorites popup lets you switch between different tool settings. So if you were using the pen tool, you could tap a favorite stamp in the stamp popup to both activate the stamp tool and switch its settings to match that favorite. You'd then still need to press on the score to create that stamp. The one thing is that the favorite popup has to be dismissed before you can tap on the score to create something. That requires a tap. If you haven't done this yet, you can long press the favorite icon in the radial menu or click the outer arrow to bring up a floating favorites window that you can drag around and have available for quick access. For users that are going to swap between favorites frequently, this may be more convenient than having to bring up the favorites window each time to switch tools. This would avoid the problem you are currently encountering.

One thing I can consider doing is dismissing the favorite window if a favorite is tapped. This would eliminate the need to tap to dismiss the popup. If users prefer that, that is an easy change to make.

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15