MobileSheets Forums

Full Version: First stroke upon entering annotation mode often disappears when exiting
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hi there,

I'm using the e-ink edition of MobileSheetsPro, version 3.2.8, on a Boox Max Lumi.

Quite often, the first stroke I draw after entering annotation mode disappears when I exit annotation mode. This is when using the pen at size 3, 100% opacity, black, Smoothing set to None, without Pressure or Dashed checked.

I can pretty reliably reproduce this - like 8 or 9 of 10 tries. It doesn't seem to matter what PDF I have loaded, or what the smoothing setting is. The Boox app "optimization" is disabled for MobileSheets, and it's using the default app DPI (212).

Once it manages to save a stroke, I can't as readily reproduce the problem until switching pages (it does happen but less reliably). But then I can switch back to the original page and see the problem almost every time.

I thought maybe it was a timing issue, but it seems to happen even if I enter annotation mode and wait for a few seconds before drawing.

I made a video (not very steady, sorry) that shows the problem in action:

Please let me know if there's any other information I can provide to help debug.

I have the same configuration. 
Up till now I was not able to reproduce your problem
My settings:
Dpi 350.
As far as I can check, other setting are equal.
By the way, I use Dutch language in Mobilesheets. 

In your video it seems that you exit the anotation mode by touching the screen with your finger, I can not find such a setting?
WilNL - does that mean you also can reproduce the problem now? I'm running through some tests right now on my BOOX Max 2 Pro, and I definitely can't reproduce the problem described here. I'm thinking I may need to get a newer model like the Lumi in order to see some of these issues.

John - Out of curiousity, if you enter the annotations mode, switch tools, then switch back to the pen tool, then annotate, does it correctly save the stroke in that situation? 

Sorry for my English.
I tried a lot of times to reproduce the problem of John, but at my device I never have the same issue. (It looks that I have the same tablet and the same software version) 

WilNL: In the annotation settings, I've set Three Finger Tap to exit the annotation mode. (This happens even if I exit by touching the X at the top left, though.)

Mike: It still sometimes drops the first stroke even if I switch tools before drawing.

I did notice something else just now, though: the loss happens when switching to the eraser (or any other tool) - I don't have to exit annotation mode to trigger it.

It seems to happen far more reliably if I enter annotation mode by tapping with the pen rather than e.g. a three-finger tap on the page.

I tried turning off "Automatically save changes" and "Combine freeform annotations" - neither seemed to have an effect (so I've put them back at their defaults of "60 seconds" and "checked").

I just tried un-checking "Enable Touch input in Stylus Mode". That actually seems to make the problem go the expense of having to tap the tiny X in the top left whenever I want to exit annotation. Not sure if you have tried with that option enabled, but that does seem to be highly correlated with my problem.
...and I just reproduced with "Enable Touch input in Stylus Mode" unchecked. It just doesn't seem to happen as often.
John: I don't have that option (to be sure that I didn't miss something, I switched to English language) I have only the option to enter anotation mode? 

Further to the problem, I have tried some of your mentioned settings, I still are not able to reproduce your problem.

Greetings, Wil
I'm not sure I'll ever see the problem on my BOOX Max 2 Pro, but I'll keep trying. It might also depend on what file you are testing on, because one user contacted me with an issue that only seemed to happen with a particular file, which is strange as that shouldn't have an impact. Have you tested with multiple songs? Does the same issue happen in all of them?

Hi Mike,

I haven't tried on every file, but I've seen it on a wide range of them - vector-based PDFs directly from publishers, my own scans, and scans that someone else did (I assume on a different scanner model). All of these are PDFs.

In case it's an unexpected interaction between multiple features, is it possible to export all of the settings to import on another device?

On the plus side, it really seems to happen less frequently without the "Enable Touch input in Stylus Mode" setting checked, and it's not too bad to either touch the top-left corner X with the stylus or mash the physical back button on the tablet to get out. (Disabling that option also avoids another slight pain point, where every once in a while, using the eraser-button end of the stylus is interpreted as a panning gesture before it registers that the eraser button was pushed.)
In case it happens to help Mike or WilNL reproduce the issue, here's a screenshot of the annotation settings that I can reliably reproduce with.

The only thing I've changed with notable reduction in the probability of missing the first stroke is to uncheck the "Enable Touch Input in Stylus Mode" checkbox.

(Edit: replaced "check" with "uncheck" - oops.)
John & Mike:

Yes, now I can reproduce the problem! 
With the same settings I have reproduced the problem now for the first time.
For me it looks as if the way of exiting the anotation mode matters. (with 3 finger tap).
I see that while reproducing the problem, the eraser icon in the top of the screen becomes actieve.
In your video I see that you use 3 three finger tap to close the anotation mode with the stylus in your hand.
Possible this is the reason of the problem?

I can readily reproduce no matter how I exit annotation mode, whether with three-finger tap, stylus-touching the top left X, or pressing the physical back button on the tablet.

I did find that if I enter annotation mode by touching the screen with the stylus, I can reproduce a lot more readily than if I enter with a three-finger-tap. And exiting with the three-finger tap does seem to cause it somewhat more reliably than the other exit methods (and it doesn't make a difference whether the stylus is in my hand).

Just to be sure it wasn't actually a split-second tool-switching issue, I also set the two-finger-tap action to None, and found the same results.
It actually seems like entering with a three-finger-tap, rather than by touching the screen with the stylus, is just as reliable of a workaround as disabling touch input in stylus mode.

It's almost as if MobileSheetsPro is trying to avoid recording that initial tap as an annotation stroke, and winds up ignoring the next stroke instead/as well. There doesn't seem to be a real "stylus near the screen" indicator with the Wacom-tech stylus used here - so I assume the OS sends that signal to an app when the stylus first touches the screen. With touch mode enabled, maybe the position for the first tap (which I am just speculating MSP is trying to ignore as a stroke) gets interpreted as a finger touch instead of a stylus touch, and then the first stylus stroke is ignored? (Or the events are handled asynchronously and complete out of order?)

Just throwing out ideas (but I'm pretty satisfied with the enter-with-touch workaround).
Thanks for all the information and feedback John. I'm not able to see the problem on my BOOX Max 2 Pro, but I'm working on getting a Lumi for testing so that I can investigate this in a more proper manner. I can certainly work with you or anyone else on gathering a lot of diagnostic information about the touch and stylus input so we can figure out if things are getting processed in an unusual manner, or we can wait until I have a Lumi to test on to see if I can reproduce the issue and get a fix in after that.

Hi Mike,

Hate for you to buy a niche device just to reproduce a weird issue that's not hard to work around. It is a really nice tablet, at least...

I'm happy to help gather information any way I can.
Pages: 1 2 3