MobileSheets Forums

Full Version: Android fire 10 tablet loses connection after about 120 imports
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Using mobilesheets 3.7.2. Connected to companion, 3.1.9 via usb. Start import of 835 files in 46 folders. I've done this same operation dozens of times over years (many files there get added, edited, deleted). Now, after restarting and rebooting and trying about ten times, the import stops either at 125 files or 199 files because it loses connection. The following is displayed:

Error While Sending
Error encountered while sending data to tablet:
System.Net.Sockets.SocketException (0x80004005): An existing connection was forcibly closed by the remote host at System.Net.Sockets.Socket.Send(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags) at MobileSheetsCompanion.SocketConnector.SendSongUpdate(String inputPath, String outputPath, List'1 songs) in C:\MobileSheetsPro\MobileSheetsCompanion\MobileSheetsCompanion\Sync\SocketConnector.cs:line 570.

Reconnect the tablet and try again.
Have you tried restarting the router?

(03-18-2023, 10:14 AM)Geoff Bacon Wrote: [ -> ]Have you tried restarting the router?


As I stated, it is a wired USB connection to the PC.
So, just to be clear - you installed the Universal ADB drivers for your tablet in order to use the USB connection feature in the companion app? Most users don't utilize that feature, as it can be a pain to get working correctly (as you also have to enable USB debugging and such on the device), so I just want to be absolutely sure. Just having the device connected with a USB cable will not cause MobileSheets to connect over USB - it will still use WiFi unless you specifically use the USB connection option in the companion app.

As far as the error, if it's always happening on the same two files (125 and 199), can you do smaller batches like 50 at a time so we can try to narrow down the scope of the problem? It's possible MobileSheets is having an issue with specific files that are being imported.

Device full? unlikely but worth a check

I got it fixed this morning. First, storage has 9GB free so that's not a problem. Second, yes, I use USB connection just fine, all working there.

So, what I found is that I had 455 files in 17 subfolders. Also, I had mistakenly extracted all 455 files and 17 subfolders to a sub-subfolder! So there were 455 songs in the folder I was importing and the same 455 songs in a subfolder with the same names but different dates. Once I removed that sub-subfolder, and also deleted the collection from the tablet to start afresh, the import worked. As a software engineer, I can't quite figure out why the import would care about this; it seems it would just overwrite the existing duplicate file. But anyway, something about having the sub-subfolder with the same files caused a problem.
Sounds like it probably caused some kind of error in MobileSheets. I'll have to look into that.