• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[ Solved] Unstable operation CME Widi Master and Android 13 (Samsung TAB S7)
Hello folks,
I'm new to the forum, my 1st post today!

I'm a keyboarder in a rock & pop band and have my sheet music for years on tablets, but with another software package.
During the last days I migrated easily (thanks to import and export functions for chordpro and pdf files) to MobileSheets - that's a really good tool!

Inspired from the ability to send midi data with selection of a new song, I entered a few values for my Stage 4 keyboard.
Connected per USB everything was stable and fine.

I have a second board, it's a Roland AX-Synth. Connection via USB works fine as well, but only one board at the same time.
So I bought a (first) CME Widi Master.

I got it working and everything worked fine during our practicing session last evening.
Today tried one more time - no reaction on the Stage 4.

I searched the forum and found no solution so fare.

Original set-up:
- WIDI Master set to connect to PC only
- WIDI Master renamed (in the WIDI app) to "ST" (I planned for a second WIDI Master named "AX")
- WIDI Master "ST" is listed in the Samsungs bluetooth menu, pairing works as usual. (Without paring no connection to the WIDI app).
- MS Midi set to "Google" and input / output channels are connected
- MS shows two pop-up's after start of the app "midi device ST was connected" and a bit later ".......... to ST(0)" 

That worked yesterday.

This morning I connected the WIDI Master to my Roland keyboard.
No reaction when selecting a new song on MS, no data echoed in the editors midi menu "MIDI-Befehle empfangen" 
A defect? No connection per USB works as desired.

So back to the Stage 4 and connect WIDI Master again.
No reaction, except data is shown in the editors "Receive MIDI signals" menu. There I can see note on and off etc.

Now the second WIDI Master arrived. Renamed to "AX" and same procedure as with the "ST".
What shall I say? Works fine!

Switched off the Roland AX, went to rehearsal room, switched on the Nord Stage - worked, then the AX-Synth - worked - wow!
- -
In the afternoon I wanted to give it another try. Started MS, switched on the boards - no reaction when I select a new song.

What have I tried?
- All trials with the "ST" called WIDI Master only, "AX" stays off.
- Deleted from pairing to TAB S7
- Reboot Tab S7 several times
- WIDI Master reset to factory settings
- Sometimes the WIDI App doesn't find it's own devices
- Tried MS with and without paring (BT midi problems with Android 13 have been mentioned in this forum)
- Tried MS with and without "google" library. Sometimes I get MS receiving data in the editors menu when I select the "predefined" library.

My question:
Did someone of you get a stable working WIDI Master with Android 13?
What settings used on WIDI Master and MS?

Kind regards,

P.S. A keyboard to keyboard connection with WIDI Master worked perfect. It's a pity, I cannot set the Stage 4 to echo midi data received over USB on the DIN connector.
Double entry. Sorry
just tried the midi connection on a Samsung Note tablet running Android 5.2
MobileSheets works, WIDI is detected with pairing.
No new setup is selected with a new song, but in the editor midi data is shown.
Receiving of data works, sending not.

I've definitely done a fair amount of testing with the CME WIDI Master, and in general, it seems to work pretty well with my mioXM and my Yamaha SX600. I posted about one issue here: https://www.zubersoft.com/mobilesheets/f...l#pid40435

It seemed to work best for me if I did not pair it, and when the pairing request occurred, I canceled it. I can certainly try downloading the latest updates/firmware for the WIDI Master and retest it with my S8 Ultra though. 

As far as your Android 5.2 device, the Google MIDI library is only available for Android 6.0 and higher. For earlier Android versions, MobileSheets has to fall back to the legacy bluetooth implementation which uses an open source library. While I have tried to make improvements to it, it feels less reliable than Google's implementation. Android 6.0 is eight years old now, and the vast majority of users have devices running an Android OS version greater than 6.0. So I don't think there are many improvements I'll be able to make in regards to this...

Thanks for fast response.

My WIDI devices report as bluetooth firmware and as hardware revision.

Latest findings:
Both adapters show the same behavior, I expect no hardware fault.
Unpaired both devices, swichted bluetooth off/on, rebooted Tab S7, response does not change:

- Using "default" lib: both devices react on midi signals (editor, midi menu)
- Using "google" lib: no response
- Both devices do not send midi signals with Mobilesheets (Nord Stage has a monitor led for that)

As well:
- WIDI unpaired, Keyboard "Off" no power, start MobileSheets, pop-up window "Connected to Device xy"

My WIDI devices have the following settings. Perhaps that's the fault.
- one adapter renamed to "AX", the other or "ST" (via WIDI app)
- devices set to "PC" (miss the real naming"), so no connection amongst each other

- Both devices removed only with power off

What else can I do?

Just made another test on MacOS 14.1
Opened the app "Audio-Midi-Setup" and connected to CME WIDI-Master via bluetooth with pairing.
I started the app "MidiPlayerX" and the connected board (in this case my Roland AX) played the sound.

Means: The adapter is working

Second test on Android 5.
I deleted Mobilesheets and downloaded from the backup w/o settings.
WIDI-Master is connected without pairing and data is shown in the editor menu when I hit key on may Roland.
No data can be sent to the keyboard.

--> The problem seems to be related to Android.
Now I installed Mobilesheets on my MacBook Air M2.
Loaded my backup from Dropbox w/o restoring settings.
CME Widi Master (firmware 2.2.1 once more installed via iOS app) is detected, paired and connected.

--> No data is transferred during changing to a no song
--> Editor windows (midi menu) shows received data

Finally I connected the Stage 4 with the Roland AX with my two WIDI Master.
Both boards play the notes of the other. The adapters work perfect!

I'll give it up!
I'll run more tests with my WIDI Master when I get a chance (juggling a huge amount of things right now), but the last time I tested this, it worked on Android, Windows and iPadOS with MobileSheets, and I could send and receive messages with my Yahama SX600 (I used the linking functionality which requires two-way communication). So I'm not sure what is different about your setup. It seems like you've done very thorough testing, so I'm not sure what else I can recommend at this point.

Thanks Mike, for keeping me optimistic hi.
From my point of view a root cause might be the new firmware 2.2.1 
There is no way to roll back 2.2.1 to earlier version, thus my options are mostly gone.

So if you find some time these days to update your CME WIDI Master, we will see the possible influence on sending Midi data from Mobilesheets.
But - as my Android setup behaves the same as the iPad (ok, MacBook might be different) installation. that would imply a common library in both of your apps based on the same or similar code having an issue with the new 2.2.1 firmware.

I could install Mobilesheets as well on my Acer Spin Notebook. But that's difficult, as I don't have a payment assigned to MS store and the Spin runs WIN11 already. Acer does not ship WIN11 drivers for my Notebook and audio and power-management drivers are not compatible and cause problems in day to day operations.

What do you mean by "two-way communication"? Is this a special set-up somewhere?

I'll stay tuned!
I just meant that in order to use the Genos/SX keyboard linking feature, MobileSheets has to send requests to the keyboard (using system exclusive messages) and the keyboards answers with system exclusive messages for the current registration. So by "two-way", I just meant that in order for this feature to work, both sending and receiving of MIDI messages both have to work.

Hi Mike,
I now, you'll dig in my problem when you have some time.

Today only one question:
Could you provide your actual CME-Master firmware installed?
I could downgrade to older versions with the "!WIDI" app (Android and iOS).

It looks like I was testing with of the bluetooth firmware version and hardware version I'm updating to version 2.2.1 right now to see if it still works for me.
I was able to get one-way communication through the WIDI Master, but it was not responding to any messages I tried to send. So I could only receive. Very strange... I tested with the WIDI Jack and it works fine though.

Wow, exactly my find on Android an MacOS. Tomorrow I will downgrade my WIDI Master to and report here in the forum
Based on my testing, I believe the WIDI Master is at fault here. I'll have to contact the company that makes it to get more information.


Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.