• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Why usually 2 mouse clicks to turn page
#1
Strange behavior on my HP convertible laptop, and I believe on my Asus Chromebook also.  To turn a page I usually have to use two mouse clicks.  Sometimes it works with one click, but usually two is needed.  I changed the option under "file options" in Windows 10 to one mouse click from two, but the problem persists.  Any ideas?
Reply
#2
I definitely can't explain that as a single mouse click is all you should need if you are clicking on the sides of the page. You could also consider using a key command to turn the pages such as page down or right arrow (those are mapping under Settings->Touch & Pedal Settings->Pedal Actions).

Mike
Reply
#3
(08-26-2021, 06:10 PM)Zubersoft Wrote: I definitely can't explain that as a single mouse click is all you should need if you are clicking on the sides of the page. You could also consider using a key command to turn the pages such as page down or right arrow (those are mapping under Settings->Touch & Pedal Settings->Pedal Actions).

Mike

I'm using the laptop in tablet mode, so no way to quickly use key commands.  I should add I tried several different mouses (or mice?) with the same behavior.  I have a new Logitech mouse arriving today, and hopefully that will fix the problem.  If not, it's something I will have to live with.  The problem is on live gigs, where every second counts in turning pages.
Reply
#4
Perhaps the first click is used to focus the control and the second is then accepted to invoke an action?

If this is the case, and it is a big if, then MSP could focus the page so that the first click does what is expected.

Geoff
Samsung Galaxy Tab A6
Reply
#5
Did you enable Settings->Touch & Pedal Settings->Treat Mouse Click as Pedal Press? If so, what pedal debounce setting is set under Settings->Touch & Pedal Settings->Pedal Actions? I need to know how you are utilizing the mouse in this case for the page turns.

Mike
Reply
#6
(08-27-2021, 03:00 AM)Zubersoft Wrote: Did you enable Settings->Touch & Pedal Settings->Treat Mouse Click as Pedal Press? If so, what pedal debounce setting is set under Settings->Touch & Pedal Settings->Pedal Actions? I need to know how you are utilizing the mouse in this case for the page turns.

Mike

I have it set now with Debounce: disabled, Scroll Speed: Immediate, and Fixed Duration: 1
The original setting was different than these, but the new settings didn't fix the problem.
I am using the mouse as right click turn page forward, left click turn page back.

Btw, the new Logitech M325 mouse I just bought didn't solve the problem either.

It's really a minor annoyance, and I find instead of hoping the page will turn with one click, I just hit it twice and that will always turns the page.
Reply
#7
It looks to be an issue when pedal debounce is disabled. At a quarter second, I didn't see the issue, but I of course had to wait slightly between clicks. I'll look into this.

Mike
Reply
#8
I have located the problem - there is code that basically forces a 1 second debounce equivalent for mouse clicks to prevent double-clicks. I'm going to drop that when the mouse click is treated as a pedal press, and I'm also going to cut that down to 100ms in other cases.

Mike
Reply
#9
(08-29-2021, 09:27 AM)Zubersoft Wrote: I have located the problem - there is code that basically forces a 1 second debounce equivalent for mouse clicks to prevent double-clicks. I'm going to drop that when the mouse click is treated as a pedal press, and I'm also going to cut that down to 100ms in other cases.

Mike

Great job!  Thanks for taking the time to investigate the issue.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
2 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.