• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible to use Backup Restore to set up new user?
#1
I'm not sure if this is the right place to post this, but here goes...

I use MobileSheets in our church choir, and a fellow choir member got a Samsung 10" tablet (I don't remember the exact model) for Christmas, so I thought I would help her set it up. Since I've already manually imported over 500 songs, I figured the best way to get her set up would be for me to make a backup (including image files), then copy the backup file to an SD card, insert that card in her tablet, and do a restore there. However, when I do the restore on her system, it gives me the "Restore Complete" after approximately 1 millisecond (way too fast), and of course there are no songs present. There isn't an error message to tell me what went wrong, so I'm at a loss of how to proceed. If any of you have already done this & have been successful, please let me know what you did. I noticed that there were several options in the restore menu for the copy location: it defaulted to SD Card, which is the first choice I tried. When it didn't work, I tried each of the other options, but I got the same "instant completion with no error message" result.

I only had a limited amount of time to try restoring last time, but one thing that occurred to me after the fact was that her tablet didn't have the same "removable storage location" path as my tablet. Is that a requirement for a successful restore? If so, I can probably fix that when I try again (i.e. set her removable storage location to be the same as mine).

Thanks in advance,
- Mike

[Edit: just to clarify before anyone asks: she does have the paid version of MobileSheets, but I can't answer for sure if she is using the same version that I have. Also, I made the backup when I was running v3.9; will there be a problem restoring that on a tablet running v4.0? [I hope not! Otherwise, how can I restore if my database gets wiped during an update?] )
Reply
#2
There should be no issue between those two versions. What is the size of the backup file? I'm worried that for some reason it has the database, but no actual files in it. When you did the backup, you didn't uncheck any options, did you?
Reply
#3
(01-15-2013, 04:16 PM)Zuberman Wrote: There should be no issue between those two versions. What is the size of the backup file? I'm worried that for some reason it has the database, but no actual files in it. When you did the backup, you didn't uncheck any options, did you?

The file is 597MB. I didn't uncheck the box when I made the backup, and I made the backup using the Android app, not using the companion (although I might try a second backup from the companion just to see if I have different results)

One further thought: since installing the program on her tablet, I don't think she has actually created any songs. Would it make a difference if we manually added one song before trying to do a restore, just to "prime" things? (i.e., maybe your app doesn't create certain tables/items until a song is added)

EDIT: I just made a backup via the companion, and the .msb file is the same size.
Reply
#4
Well it definitely sounds like the backup file is fine. It shouldn't make a difference whether her library is empty before doing the restore. The database tables are fully populated after the initial load.

There shouldn't be an issue with going from v3.9 to v4.0, or any newer version for that matter. The database in the backup file is upgraded to match whatever version is current. Going from a newer version database to a lower version database could potentially cause issues though. I don't really have downgrade code implemented at the moment. If there was some critical error during this process, an error message would have been displayed. I'll continue looking for possible reasons for this issue. Obviously if I had a copy of your backup, I could debug the code while restoring it to try and track down issues. If this is something you are willing to do, let me know, otherwise I will keep digging on my end.

Is it possible for you to upgrade both tablets to v4.0.1 and try again? It would help eliminate any possible errors due to versioning, even if theoretically there shouldn't be any.
Reply
#5
I had slightly different results last night at choir practice. As I mentioned above, when we first tried to do a restore, it came back instantly as though it hadn't done anything. So last night, I first created the same folder structure for Removable Storage Location as I have on my tablet, and I set that folder as the RSL. This time when I did a restore, it displayed an error message that was something like "Corrupt file, skipping data" for about a minute, then it displayed another message saying that the restore was complete but that not all songs were processed (I'm sorry for the inexact messages, but I didn't have time to take a screen shot or write down the exact text). I tried a restore twice, once with the location set to SD Card, and once with it set to Removable Storage Location. I got the same results both times.

However, here is the punchline: after trying these restores, I discovered that her tablet has 3.8 (from the Amazon App Store). I told her that the version mismatch was most likely the reason why the restore failed. Unfortunately, there was no wifi available at practice last night, so we couldn't update the app. She will update the app to 4.0.x and we'll try again next time.

Addendum: It looks like the latest version on the Amazon App Store is 4.0. Do you see an issue with restoring a 4.0.1 backup into 4.0? Or should I wait until she can download and install the 4.0.1 update?
Reply
#6
There are a couple of bugs in the database handling in v4.0, but you should still be safe to perform the restore. Another backup should be made before upgrading to v4.0.1, but Amazon takes a bit to approve the updates so that could be a week. Definitely keep me posted on how it goes. I'll try to reproduce those issues based on your descriptions.
Reply
#7
(01-18-2013, 01:38 AM)Zuberman Wrote: There are a couple of bugs in the database handling in v4.0, but you should still be safe to perform the restore. Another backup should be made before upgrading to v4.0.1, but Amazon takes a bit to approve the updates so that could be a week. Definitely keep me posted on how it goes. I'll try to reproduce those issues based on your descriptions.

Interestingly, I just got an email from the tablet owner, telling me that after she updated the app to 4.0, she was now able to see all of the song titles for the restore we did, but none of the actual files were present (i.e. when she tries to view a song, she gets a "not found"). She's going to try to restore again (after I give her the backup file) and let me know how it works.

Thanks again for your help on this.
Reply
#8
Update: After a few more tries, she finally got it to restore without any errors. I wasn't present when she did the restore so I can't tell you exactly what she did, but everything appears to work now.

Thanks again for your help.
Reply
#9
I'm glad to hear you got it all working.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.