• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"This app may not be optimized for this device"
#1
So, went to update and saw this message about may not be optimized for this device.  I don't remember ever seeing this before.  I did not update out of concern of screwing up what is working and not knowing what effect this update will have.  Is this a problem or not?  Not sure if safe to download at this point.

I have android 6.0

I also noticed that devices pre-4.0 will no longer be supported.  Makes me wonder if the same will eventually happen to 6.0
Reply
#2
Well, what device are you using?

Where are you attempting to update from? (what store)

I have used MobileSheets on a range of devices, even a very old cellphone with only a 3.5" screen! (not very useful, but it works!)

I am using MS on an old tablet with Android 3.2!

It works fine in all cases.

The Play Store won't let me update the Android 3.2 tablet, so I have to use a workaround...but that's another story.
I could be wrong, it happened once before.
Reply
#3
That's very odd that you are seeing that message. Google refuses to let me list the app as "optimized for tablets" due to complaints about "wasted space" in the user interface. There was another thread about this, but I've basically given up on it for now.  I wonder if the message is related to that though.

Android 4.0 was released in 2011. That is the new minimum version, as you stated, and will most likely be the minimum version for a long time to come. I supported Android 2.3 since the initial release in 2015, and 2.3 was originally released in December 2010.  So I imagine I will be able to support 4.0 as the minimum for another couple years at least. This is all driven by what Google stops supporting with their libraries.

Mike
Reply
#4
(11-06-2017, 08:44 AM)Zuberman Wrote: That's very odd that you are seeing that message. Google refuses to let me list the app as "optimized for tablets" due to complaints about "wasted space" in the user interface. There was another thread about this, but I've basically given up on it for now.  I wonder if the message is related to that though.

Android 4.0 was released in 2011. That is the new minimum version, as you stated, and will most likely be the minimum version for a long time to come. I supported Android 2.3 since the initial release in 2015, and 2.3 was originally released in December 2010.  So I imagine I will be able to support 4.0 as the minimum for another couple years at least. This is all driven by what Google stops supporting with their libraries.

Mike

So, do we know if it's safe for me to update or do I just leave it as is?
Reply
#5
Yes, it's perfectly safe to update.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
2 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.