• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
is Time Travel Debug (TTD) useful for debugging this problem?
#1
Hi Mike,
 I'm still seeing this problem off and on over the past few weeks. I see one user gave you a TTD file. Was it useful?
I can create one for you if it would help.
 If some system process was causing the hanging, wouldn't that process show at the top of the Task Manager cpu or memory performance list? But...
  Nowadays, when I run MS, I always also have the Task Manager running to see what's happening. Every time MS hangs, I can see the CPU jump to a max of 20-30% (MS is most of it), and memory does not go over about 60-70%. It does not appear to be a CPU or memory problem IMHO. Lately I run MS and the TM only, so the machine is lightly loaded. I also run with no wifi and no Bluetooth.
  Is there a way to view the loading on the GPU? Any other system/component/process to watch to get more hints?
thanks again,
Rod
Surface 4
TuneLab
Reply
#2
Hello Rod,

The previous file that was shared with me was useful in the sense that I could attach a debugger and see what code was being executed during the long delay. The unfortunate result is that none of my code was actively being run - the code that was executing was all in the Microsoft framework, so I have no idea what it was doing. If you capture a TTD file, I'll be happy to check it out to see if the result is the same. 

The main problem is that, even with testing on four separate windows 10 machines, I've only ever seen small pauses during UI updates. I've definitely never seen extended 10+ delays like you are describing. So without being able to actively reproduce the problem, I really don't know what to look for. I could set up extensive logging to try and measure the time each section of code is taking, but this will only really work if we have an idea about what code to isolate the timing tests to, as there is far too much code otherwise. If you have an idea about what actions cause the delay and you want to test out some custom builds, I'll be happy to work with you on that. I'll just have to send them to you over email.

Thanks,
Mike
Reply
#3
(07-31-2019, 02:39 PM)Zubersoft Wrote: If you have an idea about what actions cause the delay and you want to test out some custom builds, I'll be happy to work with you on that. I'll just have to send them to you over email.

I'd be glad to try out some custom builds for you.

This is mostly when I see this problem: I first select an artist, viewing the artist's list of songs. The delay usually happens after I select a song to view from the artist's song list. It then hangs (continuing to show the artist's song list page; MS not responding to any user inputs) for up to 10-25sec before it actually opens the song. Sometimes it also happens when I'm returning to the artist's song list from viewing a song.

Does that help define what to put in a custom build?

Thanks for continuing to look at this issue,
Rod
Surface 4
TuneLab
Reply
#4
It does - that certainly seems to point to the unloading or loading of PDFs as the main issue (although that is just a guess). I'd be curious if you encounter the same problems using image files, but I won't make you go through that. I'll try to get you a custom build as soon as I can, but I'm going to have to travel for my day job tomorrow, so I might not be able to get that to you until later in the week. I'm glad that I won't be having to split my time like this for too much longer.

Thanks,
Mike
Reply
#5
(08-05-2019, 03:54 AM)Zubersoft Wrote: It does - that certainly seems to point to the unloading or loading of PDFs as the main issue (although that is just a guess). I'd be curious if you encounter the same problems using image files, but I won't make you go through that. I'll try to get you a custom build as soon as I can, but I'm going to have to travel for my day job tomorrow, so I might not be able to get that to you until later in the week. I'm glad that I won't be having to split my time like this for too much longer.

Thanks,
Mike

Good plan, Mike.
thx,
Rod
Surface 4
TuneLab
Reply
#6
fyi....I caught it today doing the delay thing when entering and exiting a .png file, so it appears it's not just a pdf issue.....
Surface 4
TuneLab
Reply
#7
That's good to know - thanks for checking that.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.