• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MobileSheetsPro on Chromebook displays incorrect IP address
#1
Sad 
When I click on "Connect to PC" on my Chromebook, the pop-up screen for the wi-fi connections displays the incorrect IP address for the tablet on my home network.  I cannot find a way to change the static IP address back to what the Chromebook wi-fi settings show to be the local IP address.  Does anyone have a solution to this issue?
Reply
#2
Chromebooks are a little interesting because they have a built-in firewall and the way they handle network may also involve a NAT. When MobileSheetsPro looks up the local IP address, it iterates over all available network interfaces and uses the first IPv4 address that is found that isn't the loopback address. It's possible with Chromebook that there are multiple network interfaces involved. Regardless, broadcasting is blocked by the firewall, so you won't see a connection pop-up on the PC running the companion app. This means you need to use the Connection->Manual WiFi Connect option in the companion application. Just enter the correct IP address when doing that and it should all work. Let me know if that is not the case.

Mike
Reply
#3
(09-12-2019, 05:34 AM)Zubersoft Wrote: Chromebooks are a little interesting because they have a built-in firewall and the way they handle network may also involve a NAT. When MobileSheetsPro looks up the local IP address, it iterates over all available network interfaces and uses the first IPv4 address that is found that isn't the loopback address. It's possible with Chromebook that there are multiple network interfaces involved. Regardless, broadcasting is blocked by the firewall, so you won't see a connection pop-up on the PC running the companion app. This means you need to use the Connection->Manual WiFi Connect option in the companion application. Just enter the correct IP address when doing that and it should all work. Let me know if that is not the case.

Mike
Reply
#4
(09-14-2019, 04:10 AM)WJSelf5022 Wrote:
(09-12-2019, 05:34 AM)Zubersoft Wrote: Chromebooks are a little interesting because they have a built-in firewall and the way they handle network may also involve a NAT. When MobileSheetsPro looks up the local IP address, it iterates over all available network interfaces and uses the first IPv4 address that is found that isn't the loopback address. It's possible with Chromebook that there are multiple network interfaces involved. Regardless, broadcasting is blocked by the firewall, so you won't see a connection pop-up on the PC running the companion app. This means you need to use the Connection->Manual WiFi Connect option in the companion application. Just enter the correct IP address when doing that and it should all work. Let me know if that is not the case.

Mike
Mike,

I thought that I sent you a reply by email, but I cannot find it in my "Sent" box.

I tried that several times, but it would never work.  I rechecked the IP address for the Chromebook on our home network, and it remains what it always has been, which is not what shows up in MobileSheetsPro.  I cannot find a way to correct the IP address in the MobileSheetsPro "Connect to PC" pop-up window.

I know almost nothing about Chromebooks or anything running a Google or Android OS.  I bought this Chromebook for my wife only because it was shown as a highly rated device to use with MobileSheetsPro.  We do not use it for anything else.  Now, we can't seem to be able to use it for that.

Any other suggestions you or someone else might have would be appreciated.

Bill
Reply
#5
Bill,

Just so we are on the same page - you used Connection->Manual WiFi Connect, and you've tried both the IP address shown in MobileSheetsPro and the IP address shown in the device network settings? What kind of error do you get when attempting to connect like this? If it doesn't work, the problem may actually be on the PC side. Please try the following:

1) Go to Windows Firewall->Allow App or Feature Through Windows Firewall and make sure public/private are both checked. 

2) Go to "Network Status" in Windows 10, go to "Change connection properties" and make sure it's set to private. 

3) Next, load the companion app and see if the connection works. If it does not, reboot your router, as this fixes problems in a large number of cases. 

4) If you have anti-virus software with a firewall, make sure to disable that or unblock the companion app. 

Let me know if that helps at all. As a side note, the companion application is completely optional and only helps you transfer files to the device and create entries on the PC. You can do all of it on the device itself using MobileSheetsPro. You can also import your files off the cloud directly. So I don't think just because the companion app isn't working that you have to give up on the using the app altogether. The companion app just helps you set up and manage your library - actually utilizing your library is all done on the device itself.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.