• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CME WIDI Master
#16
Hello, the problem is that in edit song under edit midi midi command when selecting command type: PatchSelect the command entered will not be sent, if the
Command type: Program Change
is selected, so the selected program change number is sent and executed in the Midi device, I hope that the command type Patch Select can be activated and the set values are sent. in hope I remain
Greetings Achim!
Reply
#17
A patch select is actually multiple control change messages followed by a program change message. How are you determining that the messages are not sent? Does it work some of the time, or does it always fail for you?
Reply
#18
Hello.I have a midi control which has a midi spy, so I was able to determine that in the command type: Patsch Selekt no data is output, except for the set midi channel number. In the Command Type: Program Change mode, the midi channel number and the program change number are transmitted, and everything works properly. However, only 128 sounds can be called up in this way.
I have a Roland UM-One via USB in operation without any problems.
Only the Patch Select data have to be transferred and everything is OK. It always works.
Greetings Achim!
Reply
#19
The same code is used to send messages for both a patch select and a program change message. 

Patch Select:
Send Control Change [0, MSB]
Send Control Change [32, LSB]
Send Program Change [value]

Program Change:
Send Program Change [value]

So your MIDI spy should have picked up the program change at the very least while using a patch select, as you said that works just fine with the program change message. I'm beginning to wonder if something may be configured incorrectly with the patch select command you are trying to send. Can you please take a screenshot of the MIDI command settings so I can see how you've set it up? I want you to edit the command so I can see all of the values that are being used, whether the send MSB/LSB/Value checkboxes are checked and whether send on load is checked.

Thanks,
Mike
Reply
#20
Can you please change the MIDI library to "Google"? That library is much better at handling bluetooth connections than the default. I really only left the default there for devices that don't support the Google MIDI library. Let me know if the Google MIDI library works any better for you.
Hello in the MIDI library "Google" no automatic connection is possible when switching on the midi device must be in
MSP the connection can be set manually. (See post from 9.3.21) In the setting MIDI library in "Default" the connection is automatically established when the MIDI device is switched on and interrupted when it is switched off. With the settings
Preset MIDI Library
Connection type "USB" with cable are the patch data Signature: include your signature. (registered users only)
Posted. Why is the data not sent with the Bluetooth setting?
See pictures in my mails from March 12th, 21st.
Question why the patch select data are not sent.
Gruß Achim!
!
Reply
#21
I still think the Bluetooth connection works better with the Google library even if it doesn't connect automatically. The two libraries handle detecting and connecting to devices very differently. 

I can't answer as to why you aren't seeing data sent over bluetooth with your device. I only have one bluetooth MIDI device and it has limited functionality, so I can't perform the same kinds of tests. Perhaps other users who have devices that communicate over bluetooth can comment as to whether they encounter the same kinds of issues. I will look into getting a WIDI Master at some point so I can run additional tests. From a personal standpoint, I'm not a big fan of bluetooth both from a reliability and performance perspective.

Mike
Reply
#22
Hello because I want to use 2 different tablets and the tablets have different plugs (USB Mini B and C) I wanted to avoid exchanging cables. Since the connection via Google is quite cumbersome and does not always work immediately, I have to stick to the cable, it always works. It's a shame.
Greetings Achim!
Reply
#23
Hello, correction: it's a pity
Gruß Achim!
Reply
#24
(11-05-2020, 07:56 PM)arj14pe Wrote: A status Mike for the keep-connection-problem. In android I disabled all power optimization settings for bluetooth midi and now the bluetooth connection is stable. I will do some more tests but it looks good!

I know where to find the optimization but can't find the specific Power optimization for Bluetooth Midi. Can you tell me where to find them? Have a Samsung Tab S7, Android 11.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.