• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CSVFILE of " The Cuban Fake Book Col.1 "
#1
Hello,

it’s all in the title, would you have the . csv from this book, please?

CSV of Cuban fake book 2 and 3 too ?

Merci !

.
Reply
#2
I don't have a CSV yet, but I can provide a good starting point.

I have a list of titles, composers and the page numbers as printed in the book: CubanFakeBook.xlsx
And I have the book as PDF with PDF bookmarks.

I exported the bookmarks file CubanFakebook_bookmarks.txt (using jPdfBookmarks) that contains the correct PDF pages, did some search&replace (using Notepad++) and converted it to CubanFakebook_EditedBookmarksExport.xlsx

If I had the time to do it I would proceed as follows:
- copy the columns of CubanFakebook_EditedBookmarksExport.xlsx additionally into CubanFakeBook.xlsx
- proof-read and correct titles and composers
- use LibreOffice Calc to calculate Page Order, example formulas can be found in CubanFakeBook.xlsx
- optional: add keys
- make a backup copy of the completed XLSX file
- delete all columns that are not required for the CSV file
- create CSV using "save as" out of LibreOffice Calc

I attached all the mentioned files so you can give it a try. It's worth getting familiar with a workflow as described above, it's much faster than typing everything. Good luck, have fun.


Attached Files
.xlsx   CubanFakeBook.xlsx (Size: 10.01 KB / Downloads: 7)
.txt   CubanFakebook_bookmarks.txt (Size: 6.74 KB / Downloads: 4)
.xlsx   CubanFakebook_EditedBookmarksExport.xlsx (Size: 7.75 KB / Downloads: 5)
first language: German
Acer A1-830, Android 4.4.2 - HP x2 210 G2 Detachable, Win 10 21H1
www.moonlightcrisis.de - www.basdjo.de - www.frankenbaend.de


Reply
#3
Merci !
Reply
#4
If you're successful, please share your results.
Feel free to contact me via PM
first language: German
Acer A1-830, Android 4.4.2 - HP x2 210 G2 Detachable, Win 10 21H1
www.moonlightcrisis.de - www.basdjo.de - www.frankenbaend.de


Reply
#5
Done, is that correct ?


Attached Files
.csv   CubanFakebook1.csv (Size: 4.6 KB / Downloads: 5)
Reply
#6
There are some small issues left, see attached screenshot

1.
e.g. Alardoso;10-nov;Cuban Fakebook 1
Excel / Calc misinterpreted as date
possible solution: set the format of the "Pages" column to "Text"
2.
some typical issues of OCR'ed texts are still there (you probably used the exported bookmarks file)
e.g. bodeguero, EI - EI with uppercase I instead of lowercase l
what might help
- use a font where these characters look different (e.g. Tahoma instead of Arial, I never understood why Arial became the standard font in so many cases)
- comparing "title" of the provided files CubanFakeBook.xlsx and CubanFakebook_EditedBookmarksExport.xls
it might be helpful to copy the columns temporarily into one XLSX file and add a column with a comparison formula like =WENN(B5<>D5;"x";"") that marks lines with differences

I corrected the mentioned lines, but there are probably more of the OCR issues.

btw.: I use "Albums" for fakebook names and "Collections" for the bands and line-ups I play with, but that's a matter of personal preferences and can be changed easily


Attached Files Thumbnail(s)
   

.csv   CubanFakebook.csv (Size: 4.6 KB / Downloads: 2)
first language: German
Acer A1-830, Android 4.4.2 - HP x2 210 G2 Detachable, Win 10 21H1
www.moonlightcrisis.de - www.basdjo.de - www.frankenbaend.de


Reply
#7
(03-16-2021, 04:19 PM)itsme Wrote: There are some small issues left, see attached screenshot

1.
e.g. Alardoso;10-nov;Cuban Fakebook 1
Excel / Calc misinterpreted as date
possible solution: set the format of the "Pages" column to "Text"
2.
some typical issues of OCR'ed texts are still there (you probably used the exported bookmarks file)
e.g. bodeguero, EI - EI with uppercase I instead of lowercase l
what might help
- use a font where these characters look different (e.g. Tahoma instead of Arial, I never understood why Arial became the standard font in so many cases)
- comparing "title" of the provided files CubanFakeBook.xlsx and CubanFakebook_EditedBookmarksExport.xls
it might be helpful to copy the columns temporarily into one XLSX file and add a column with a comparison formula like =WENN(B5<>D5;"x";"") that marks lines with differences

I corrected the mentioned lines, but there are probably more of the OCR issues.

btw.: I use "Albums" for fakebook names and "Collections" for the bands and line-ups I play with, but that's a matter of personal preferences and can be changed easily


yes,

I don’t know how to solve the problem, 10-nov ( instead of 10-11 ) etc... I have put a "text" format for the cells but I always have a date instead of 10-11 when i open again

if someone knows the tip for excel I’m a taker.

P.
Reply
#8
Thanks you for correcting this CSV
Reply
#9
Here is a new version of the CSV slightly improved and with the composers


Attached Files
.csv   Cuban Fake Book Vol.1.csv (Size: 7.05 KB / Downloads: 7)
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.