• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connecting MSP with Ketron SD40
#1
Hi guys,

I'm trying since couple of days to hook up my sound module Ketron with the tablet so I can send the midi to Ketron. Basically when Im changing sheets I want to change also the registrations on Ketron.

Have anyone tried and can support me? So, It seems the MSP its not recognizing the machine, even I use a midi cable inserted into Ketrion and USB in the tablet.

a lot of videos on yt with ipad that is working but nothing for android..

any ideas what might be? how can i debug step by step if the midi cable is the problem of a sort of setting on tablet/ketron machine

Thx in advance!
Tavi
Reply
#2
So the first thing I'd like you to do is go to Settings->MIDI Settings->Configure MIDI Connections, switch the dropdown to Google and see if the input and output ports show up for your Ketron. If they do, great, you can tap them to connect and we will proceed with the next steps. If they do not, there is a connection issue between your tablet and the Ketron. In that case, I'm going to need to know what kind of cable you are using to connect the devices, and if it's a micro-USB slot, whether you are using an OTG adapter cable, as that is required when using a micro-USB slot.

Mike
Reply
#3
(06-25-2021, 01:58 AM)Zubersoft Wrote: So the first thing I'd like you to do is go to Settings->MIDI Settings->Configure MIDI Connections, switch the dropdown to Google and see if the input and output ports show up for your Ketron. If they do, great, you can tap them to connect and we will proceed with the next steps. If they do not, there is a connection issue between your tablet and the Ketron. In that case, I'm going to need to know what kind of cable you are using to connect the devices, and if it's a micro-USB slot, whether you are using an OTG adapter cable, as that is required when using a micro-USB slot.

Mike

Hi Mike, Sorry as I only now saw your reply. So the problem that I have is that at configure midi connections all is grey, I cannot chose anything from there. even if I unplug the usb cable it remains grey, and there is no midi device recognized..
for the cables I'm attaching photos, I'm using a printer cable with a typical adapter, witch is working as I'm checking it with other connections..

Thx in advance! 
Tavi

a later edit, if I plug the cable, the MSP starts automatically, but there is no pop up coming that the midi device is connected and also the device is not recognized in the midi connection config in settings.


Attached Files Thumbnail(s)
           
Reply
#4
Something very strange is going on if you are unable to switch the MIDI library dropdown under Settings->MIDI Settings->Configure MIDI Connections. Please try something for me - unplug the MIDI device, tap the recent icon on your tablet and force close MobileSheetsPro by sliding it off the screen. Then restart MobileSheetsPro, go back to Settings->MIDI Settings->Configure MIDI Connections and see if the dropdown will allow you to switch it. I want you to be able to test all three MIDI libraries to see if any of them will work. 

As far as the adapter, can you please provide a link to what type of adapter that is? I also need to know what type of tablet you are using, what Android OS version it is running, and whether your tablet has a USB-C slot or a micro-USB slot. If that is a micro-USB slot and that adapter is not an OTG adapter cable, that will not work. 

If nothing else will work, the other option is to put a MIDI class-compliant device between your keyboard and tablet such as the Roland UM-ONE or the mio2. These will work with pretty much any MIDI device, and I've tested both with several tablets and the connection has always worked. The mio2 and mioXM are particularly impressive. I don't want you to have to purchase anything extra if possible though, so I want to exhaust every other option before suggesting that.

Mike
Reply
#5
(07-04-2021, 04:59 AM)Zubersoft Wrote: Something very strange is going on if you are unable to switch the MIDI library dropdown under Settings->MIDI Settings->Configure MIDI Connections. Please try something for me - unplug the MIDI device, tap the recent icon on your tablet and force close MobileSheetsPro by sliding it off the screen. Then restart MobileSheetsPro, go back to Settings->MIDI Settings->Configure MIDI Connections and see if the dropdown will allow you to switch it. I want you to be able to test all three MIDI libraries to see if any of them will work. 

As far as the adapter, can you please provide a link to what type of adapter that is? I also need to know what type of tablet you are using, what Android OS version it is running, and whether your tablet has a USB-C slot or a micro-USB slot. If that is a micro-USB slot and that adapter is not an OTG adapter cable, that will not work. 

If nothing else will work, the other option is to put a MIDI class-compliant device between your keyboard and tablet such as the Roland UM-ONE or the mio2. These will work with pretty much any MIDI device, and I've tested both with several tablets and the connection has always worked. The mio2 and mioXM are particularly impressive. I don't want you to have to purchase anything extra if possible though, so I want to exhaust every other option before suggesting that.

Mike
Mike, thank you for the reply, indeed its strange, but I hope with my explanation you can give me a solution. 
I have My Samsung S10 phone, i have installed another MSP on it in order to try and its working like charm, so it means that the problem is from my tablet or the MSP installed on the tablet. But I hope we can find the answer together.
On phone I have One UI version 3.1 , Android version 11 and I have attached a small print screen with the message I receive when I connect Ketron with a Linux system Smile


Now I will explain to you step by step because I have some experience in midi connections, I have a small music home studio so I do understand some of the things, however, why my android tablet with MSP is not working I cannot get it.

1. I unplug/restart all the gadgets -> Settings->MIDI Settings->Configure MIDI Connections its still on grey
2. As far as the adapter    https://www.amazon.es/gp/product/B0744DY...9_s00?ie=UTF8&psc=1   >>>> (but its not really matter because its working with the phone..)
3. Tablet I use    https://www.amazon.es/gp/product/B07GNT6...=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1  >>>  Samsung Galaxy Tab S4 - Tablet de 10.5 (4G, RAM de 4 GB, memoria interna de 64 GB, Qualcomm Snapdragon 835)

4. Android version 10 , One UI version 2.1

5. Extra options I've tried, I have a focusrite soundcard with midi 5 pins in/out, connecting the ketron midi 5 pins (I've tried to come out from the usb sound card into the tablet, but also not recognized), however i receive a pop window at first from MSP to allow the focusrite working with MSP, but in Configure midi connection still grey. 

Looking forward hearing from you!
Tavi


Attached Files Thumbnail(s)
   
Reply
#6
I have the exact same tablet as you (it's my primary tablet for testing), and if I go to Settings->MIDI Settings->Configure MIDI Connections with nothing attached to it, I can switch the dropdown between Default/Google/High-performance. After switching the library, it will stay gray for a second, but then it goes back to white and lets me change it. The first thing we need to do is to identify why this is not working on your tablet. If you have nothing connected, and your tablet is not behaving like this, the next thing to do would be to try installing MobileSheetsFree off the Google Play Store, then repeat the tests in the free version. If that works for some reason, and the paid version does not, then it would probably be worthwhile to backup your library, uninstall the application, reinstall it, restore your library backup and then try to switch the MIDI settings. I know this is tedious, but I don't have an explanation for why your tablet is behaving this way at the moment, so we will have to use trial and error.

Mike
Reply
#7
(07-04-2021, 10:56 AM)Zubersoft Wrote: I have the exact same tablet as you (it's my primary tablet for testing), and if I go to Settings->MIDI Settings->Configure MIDI Connections with nothing attached to it, I can switch the dropdown between Default/Google/High-performance. After switching the library, it will stay gray for a second, but then it goes back to white and lets me change it. The first thing we need to do is to identify why this is not working on your tablet. If you have nothing connected, and your tablet is not behaving like this, the next thing to do would be to try installing MobileSheetsFree off the Google Play Store, then repeat the tests in the free version. If that works for some reason, and the paid version does not, then it would probably be worthwhile to backup your library, uninstall the application, reinstall it, restore your library backup and then try to switch the MIDI settings. I know this is tedious, but I don't have an explanation for why your tablet is behaving this way at the moment, so we will have to use trial and error.

Mike

Hi Mike, I did the above steps and for some reason now its working, I can see the dropdown and I can select. Also the midi Gadget is recognized and I can manually connect it. I can send the CC messages and change registrations as described in the Manual of the Ketron. 

No idea where the issue was but I have also sent you thru application a report, maybe you can debug more. 

Thank you for this wonderful app and for your support, you are offering quality. Congrats.
Regards,
Tavi
PS
Still more questions to come, but Ill be posting on different threads in order to stay organized. Stay safe!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.