• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clock Display Settings
#1
In Clock Display Settings, I have enabled Show clock on score. I've been using this nice feature ever since it was implemented.

However, I seem to recall that it used to be in 24-hour format while it is AM/PM now. Does my memory deceive me? My system clock is set to 24-hour format.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#2
When I added support for classical terminology, I accomplished this without major changes by using a "hack" of sorts where I use the language resources for Zulu instead of English (but the Zulu resources are just the English files with "Song" replaced by "Piece"). Unfortunately, several things in the Android framework rely on the current locale, and one of those was the clock. This caused the clock to show up incorrectly on some devices when "Use Classical Terminology" was in use. So I had to copy all the framework code for the clock and modify it to use the English locale when the Zulu locale was the current locale. The code that I copied is supposed to detect when to use the 24-hour clock. It calls into java.text.DateFormat.getTimeInstance to see what the preferred format is for time. I'm not sure why this is now returning a 12-hour format for you when the previous code is returning 24-hour format. There must be something I'm missing. I think what I'll probably have to do is add an explicit setting for this in the clock settings so you can control whether 12 or 24 hour format is used. 

Mike
Reply
#3
I didn't realise there were so many factors involved...
Personally I would prefer to honour the system settings over a new, private setting.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#4
This was fixed in 3.2.6 but I noticed in 3.2.8 I got a 12hr clock. New tablet?
I needed to change the system clock to 12 hr, start and stop MSPro, change the clock to 24 hr, start MSPro and now it is 24hr again.
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#5
That's really strange - I'm not sure why you had to toggle the settings around like that. It's possible that there was no setting saved in the OS for your preference as it had never been changed, so MobileSheets couldn't find anything and defaulted to 12 hour. Once you toggled the setting back and forth, then there was a preference MobileSheetsPro could retrieve, so then it knew to use 24-hour instead.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.