• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chromebook on convertible laptop
#1
Greetings,

Here are my specifics:
Asus C436F 2 in 1 laptop/tablet (Yoga style, not removable keyboard)
Chrome OS Version 92.0.4515.157 (Official Build) (64-bit)

Pedal: AirTurn Duo BT-200

Situation: 
I am in tablet mode on my laptop, portrait orientation. Mobilesheets works perfectly. All gestures work, and the laptop style bar at the top is not there.
I connect my AirTurn Duo.
Once my pedal connects, my laptop reverts immediately to laptop mode. This breaks gestures, forcing me to tap the arrow at the reintroduced title bar to return to the library, as well as causing other problems.

I would like to remain in tablet mode, as it makes life much easier when having to swipe the screen during performance/rehearsal.

I know that this is a problem with Chrome OS, when every time you connect an external keyboard (which my pedal shows up as in the Bluetooth list) or mouse.

My question is this: Is there a way around this and remain in tablet mode? 

I have tried enabling "chrome://flags/#ash-debug-shortcuts" and trying Ctl-Alt-Shift-T.

This procedure is supposed to force a change between tablet and laptop mode. It does nothing.

Any help? I have searched here for similar topics, but nothing matches well.

Thank you for your consideration
Reply
#2
According to this post https://zubersoft.com/mobilesheets/forum...p?tid=4902 you can rotate the screen by 90 degress by pressing the control-shift-reset (or refresh- F3) keys at the same time. Does this work for you?

Mike
Reply
#3
(08-21-2021, 09:25 AM)Zubersoft Wrote: According to this post https://zubersoft.com/mobilesheets/forum...p?tid=4902 you can rotate the screen by 90 degress by pressing the control-shift-reset (or refresh- F3) keys at the same time. Does this work for you?

Mike

Thank you for your response. However, my problem is not with my computer being locked in a particular orientation.

My problem is that it exits tablet mode and returns to desktop mode. Orientation is irrelevant. Rotation happens correctly regardless of which mode my laptop is in.

By desktop mode, I mean the title bar appears at the top of the screen, and many of the swipe/gesture functions disappear. That's what I'm trying to fix, if possible.
Reply
#4
In the past, I added AirTurn Direct Mode functionality, but it caused crashes on x86 devices for some reason, so I had to pull it out. Once the AirTurn Direct Mode functionality is in place, it would give you a way to connect your pedal to the tablet without having to have it paired through the bluetooth settings. The benefit of this is that the tablet won't think a keyboard is attached, so it won't try to switch modes. I think that's probably going to be the best solution for this problem. I can try adding back the AirTurn Direct Mode functionality and seeing if I still encounter crashes on my x86 test device. Just to verify - do you have the newer Duo model that supports AirTurn Direct Mode?

Mike
Reply
#5
I was having the same problem with my Acer Chromebook and PageFlip Firefly foot pedal, when I turned on the bluetooth, it converted back the landscape and wouldn't go to portrait. I did the suggested above, control-shift-reset, to get it to be in portrait. I couldn't find anyway around it. Sometimes, rebooting my Chromebook will get it work properly. Just recently, it started working like it used too all by itself (I'm sure Mike had something to do with it...LOL!) I haven't had to use the "cheat" in awhile.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.