• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
minor UI bug
#1
I have a UI bug in the e-ink version. If the first item (Info) in the settings screen is highlighted it is shown black on black. All the other items are shown correctly white on black.

The attached screenshot shows the bug. It is taken on version 3.1.4, but the bug is also there in the current version 3.2.7.


Attached Files Thumbnail(s)
   
Reply
#2
It looks like you may have the app optimizations active on your e-ink device. Go to the home page, long press MobileSheetsPro, tap "optimize app" and turn off the optimizations. They cause conflicts with various things in MobileSheetsPro. Let me know if that does not help with this issue. I know this issue was raised once in the past, but it might have been through email, so I'll have to see if I can locate it.

Mike

UPDATE:
I did discuss this with palosanto from the forums, and ultimately could not find any way to fix this header issue. I am using Google's PreferenceActivity code, so I don't have complete control over the formatting of the settings screen or how things function. Nothing I tried would fix the issue (and I tried a lot of different things). The issue does not show up on my BOOX Max 2 Pro either, which made it harder to test.
Reply
#3
I now testet with optimizations disabled. It unfortunately remains the same. What really is strange, that it only affects the first menu item (About in english). All the other items are ok. I could test it on a Max3 and a Max Lumi. Both show  this behaviour.

As mentioned in my first post this is no big deal, I just cannot imagine a reason for it. This really is strange.
Reply
#4
There is one option that I could consider to fix the issue - no longer using the split screen view (I believe I can force Google's code to not use that). If I disable the split screen view, the headers all show up correctly, but it's a little more tedious as you have to tap a section to view the settings for that section, then hit the back button to go back to the list of sections. 

Mike
Reply
#5
I have a boox max 2 and I can't confirm the bug.

edit: In optimization I have "Whiten Apps Background" activated. Maybe that does the trick?
Reply
#6
(08-28-2021, 09:30 AM)Zubersoft Wrote: It looks like you may have the app optimizations active on your e-ink device. Go to the home page, long press MobileSheetsPro, tap "optimize app" and turn off the optimizations. They cause conflicts with various things in MobileSheetsPro. Let me know if that does not help with this issue. I know this issue was raised once in the past, but it might have been through email, so I'll have to see if I can locate it.

Mike

UPDATE:
I did discuss this with palosanto from the forums, and ultimately could not find any way to fix this header issue. I am using Google's PreferenceActivity code, so I don't have complete control over the formatting of the settings screen or how things function. Nothing I tried would fix the issue (and I tried a lot of different things). The issue does not show up on my BOOX Max 2 Pro either, which made it harder to test.

Interesting,  something has changed since then ...

I remember discussing this with you Mike and trying all sorts of things in my Onyx Max Lumi  including optimization options but  I just tried switching 'Whiten apps background' on in optimizations and seems to fix the problem.
Thanks @kabakakao.
Onyx Boox Max Lumi 13.3 -Android 10
Donner BT pedal
_________________
www.juandemarias.com
Victoria, BC, Canada - PST (UTC-8)
Reply
#7
I think the "Whiten apps background" may cause a few other issues though, such as lightly colored backgrounds becoming transparent in certain parts of the application. I can't remember off the top of my head, but if you see anything unusual, it may be related to that.

Mike
Reply
#8
(09-01-2021, 02:22 AM)Zubersoft Wrote: I think the "Whiten apps background" may cause a few other issues though, such as lightly colored backgrounds becoming transparent in certain parts of the application. I can't remember off the top of my head, but if you see anything unusual, it may be related to that.

Mike

I agree I definitely prefer the setting off for nicer display of certain screens.  I just was pointing out that something had changed since the last time we discussed the problem because I'm sure that we tested all options including enabling the whitening of bkgds.
Onyx Boox Max Lumi 13.3 -Android 10
Donner BT pedal
_________________
www.juandemarias.com
Victoria, BC, Canada - PST (UTC-8)
Reply
#9
(08-29-2021, 03:22 AM)Zubersoft Wrote: There is one option that I could consider to fix the issue - no longer using the split screen view (I believe I can force Google's code to not use that).
I think I would rather keep it as it is. It only affects some users and really is not a big thing. Maybe there is a simple solution one day.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.