• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Irregular page-turn delay with use of pedal
#1
I have been using MS free version for quite a time now, together with my Pageflip firefly pedal. Everything went always flawless, until now... 
I bought the pro version of the app and now, there's always a delay between me tapping the pedal and the page actually turning. Sometimes it turns quite soon, other times it even takes like 5 full seconds. 

I'm not sure it actually has to do with changing the app, but I can't find a solution to the pageturning delay. Any ideas?
Reply
#2
That is really strange because the free and paid versions should be identical in terms of how they handle pedal actions. I'm assuming you are testing a song that you also tested in the free version and had no problems, correct? Did you already uninstall the free version? I'm just curious if you would encounter the exact same problem in the free version now. In terms of what you can do to get past this problem, the first thing I would recommend is to backup your library under Settings->Backup and Restore->Backup Library, uninstall the app, reinstall it, restore the library backup file, then test the pedal again. I just want to rule out some weird kind of state the application is in. If that has no impact, and the pedal behaves the same with every song in your library that you've tested, then I would recommend unpairing the pedal, turning bluetooth off, rebooting the device, turning bluetooth back on, pairing the pedal and seeing if that has any impact on the issue. If that doesn't help either, let me know.

Mike
Reply
#3
(09-30-2021, 09:56 AM)Zubersoft Wrote: That is really strange because the free and paid versions should be identical in terms of how they handle pedal actions. I'm assuming you are testing a song that you also tested in the free version and had no problems, correct? Did you already uninstall the free version? I'm just curious if you would encounter the exact same problem in the free version now. In terms of what you can do to get past this problem, the first thing I would recommend is to backup your library under Settings->Backup and Restore->Backup Library, uninstall the app, reinstall it, restore the library backup file, then test the pedal again. I just want to rule out some weird kind of state the application is in. If that has no impact, and the pedal behaves the same with every song in your library that you've tested, then I would recommend unpairing the pedal, turning bluetooth off, rebooting the device, turning bluetooth back on, pairing the pedal and seeing if that has any impact on the issue. If that doesn't help either, let me know.

Mike

Hi Mike,

Thanks so much for the reply.

I did the backup + reinstalling the app, as you suggested, but it didn't help... Also unpairing the pedal didn't affect it.

I had used both free and pro version at the same time, because I hadn't transferred all my scores yet. Now the free one is uninstalled, because I thought the same issue, but nope... It was the same issue on both apps and with different scores.

Any other ideas?
Reply
#4
What kind of tablet are you currently using and what OS version are you running? Did you recently install any OS updates that could be related to this? If you plug in the FireFly pedal with a USB cable to your tablet, does it start behaving like you would expect? Another user that had a similar problem connected his tablet with a USB cable and then the pedal started working as expected, so I'm just curious if you will experience the same thing. 

I would like you to do some tests to see if this is an issue with how the pedal is communicating with the OS. Set the pedal so that it sends page up/page down commands, then load an internet browser and browse to a page that you can scroll up or down. Press the pedal and see if the page scrolls immediately, or if it exhibits the same behavior where it can sometimes take multiple seconds to respond.

Thanks,
Mike
Reply
#5
Thanks, Mike! I connected my pedal with the cable and it works perfectly! That's a relief, now I only have to find a way to make it work again with Bluetooth, because playing the piano with a cable is not very convenient for me...

I tried scrolling up and down on a browser page, it has the same delay on Bluetooth as when I use it as a page-turner. With the cable, it equally works perfectly.

I'm also feeling like it's taking longer and more difficult to connect the pedal with Bluetooth to my device. It used to go automatically within a few seconds after turning on the pedal. Now I have to go to the Bluetooth menu on my device to manually select my pedal. Most of the time, I also have to push the Bluetooth reset button on my pedal to be able to connect.

I'm using an Acer Chromebook, with Google Chrome OS Version 93.0.4577.95. When the problem start occurring, I did an update (it was still version 92..) but nothing changed.
Reply
#6
That is troubling, because that means it's an OS issue with the bluetooth connectivity. Are you currently on the beta channel? It does seem like there are some known issues with bluetooth on Chromebooks: https://www.androidpolice.com/2021/06/22...ook-again/

I think at this point, you may need to think about backing your library up to the cloud (Settings->Backup and Restore->Backup Library), then factory reset/powerwash the device, reinstall and see if it works better. I'm not sure what else to suggest.

Mike
Reply
#7
Hmm. I must say that I also noticed this behaviour on my Galaxy tabs (both S4 and S7FE). Usually MSPro responds immedeately to a pedal press, but sometimes it can take 3-5 seconds, even to the extent that I started to doubt whether I pressed the pedal sufficiently.
I haven't really paid much attention to it, but apparently it is not 'just me'...
Johan
www.johanvromans.nlwww.hetgeluidvanseptember.nlwww.howsagoin.nl
Samsung Galaxy Note S7FE (T733) 12.4", Android 11.0, AirTurn Duo & Digit.
Samsung Galaxy Note S4 (T830) 10.5", Android 10.0 (non-MSPRo, backup).
Samsung A3 (A320FL), Android 8.0.0 (emergency).
Reply
#8
Johan, if you run the same test of using an external application when the pedal starts to respond slowly like that, do you see the same behavior? I want to verify that this is an OS/bluetooth issue, because the code for processing pedal actions is incredibly simple, so I'm not sure how it could be taking 3-5 seconds to process and turn a page...

As a side note, once the iOS version is done, I'm going to add back support for AirTurn's direct connect mode which bypasses the need to pair the device. This will instead be a direct bluetooth connection between the pedal and MobileSheetsPro, which my eliminate the problems you are currently seeing with the delays. It also means the virtual keyboard won't be disabled when the pedal is connected. The only reason I haven't done this sooner is it previously caused devices with x86 processors to freeze/crash, and I didn't have a device at the time with a x86 processor to investigate it further.

Thanks,
Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.