• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't connect MSPro on Max Lumi 2 to AirTurn bluetooth pedal
#1
I've been running MSPro on my E-ink Boox Max2 Pro (Android 6) with an AirTurn Quad 200 (just like the Duo) pedal for years with no problem. I recently received my new Max Lumi 2 (Android 11). Everything setup perfectly and MobileSheetsPro runs just fine. Only problem is the MSPro Device Connections Manager running on the Lumi won't connect with the bluetooth pedal (the blue light remains blinking rapidly).

At the tablet level the Lumi 2 Bluetooth setting screen sees the pedal as available, but would not pair with it. I just installed several firmware updates available today and now the Lumi says it is paired. But it still doesn't seem to connect with the pedal. MSPro also lists the pedal but doesn't connect.

The pedal still works on my Max2 Pro. I don't know if this is a problem with the Onyx device, its firmware, or MSPro. Everything else works great but page turning is crucial.

Is anyone else using the new Lumi 2 and succeeded or failed to connect with a bluetooth pedal?

Mike Golding
Reply
#2
The Max2 uses Bluetooth 4.0 protocol
The Lumi uses Bluetooth 5.0

A web search shows that 5.0 should be able to communicate with 4.0

Do you need to unpair from the Max2 first? (or at least switch it off?)

Geoff
PS: I don't have pedals or use Bluetooth so I'm just guessing
Samsung Galaxy Tab A6
Reply
#3
Thanks for the bluetooth protocols on the two onyx devices; they should be downward compatible. Yes I did unpair and shut off the Max2 and any other bluetooth devices that popped up. I've repeatedly tried many sequences of pairing and unpairing the Lumi 2, turning bluetooth off and on, "forgetting" other devices, resetting the pedal controller and changing modes, etc.

The Lumi 2 was/is always able to connect with and send audio out to my bluetooth headphones. When I go to the tablet bluetooth screen it sees and (says it) pairs with the pedal. But MSPro never connects to the pedal from the Lumi 2 like it does on the Max2. 

Frustrating, because the new Lumi 2 screen is much brighter, clearer, with a lighter background, and updates faster than my Max2 Pro. The device speed and interface is improved, and MobileSheets Pro runs beautifully on it. I'll reach out to Boox (their help isn't as readily accessible) but I want to see if there's anything relevant in MobileSheets that can be tried or fixed.

Mike G.
Reply
#4
So you said that "MSPro never connects to the pedal". MobileSheetsPro should never be directly connecting to the pedal at all. The pedal should be set up as an HID (which is what happens when you pair it in the system settings), and then MobileSheetsPro just responds to key presses like it would from a computer keyboard. I just want to clarify this as some users have tried going to the "Connect Tablets" dialog to connect their pedal. I don't think that's what you did, as you said you had it working on your older tablet, but I just wanted to mention this just in case.

If the pedal says it is paired and the pedal is in mode 3, then you should just need to go through these steps: 

1) Load MobileSheetsPro, tap the three dots at the top right and then Settings.
2) Tap Touch & Pedal Settings and then Pedal Actions
3) Tap the "Keys" field for Pedal 1.
4) Tap the "Clear" button on the dialog.
5) Press a pedal switch. If a key shows up, the pedal is communicating properly with your device and will work with MobileSheetsPro. If it does not, the pedal is not communicating properly with your device.
6) If a key shows up, tap OK, then select the action you want that pedal to trigger from the dropdown below the keys field. Repeat these steps for pedal 2.

I'm assuming you've already tried that, but if not, does anything happen when you press the pedal while on the pedal keys dialog?

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.