• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Test Midi Connection - no response
#1
Huh Midi commands seems to be a less used part of MobileSheets and only a short description in the manual;  I'm stumped. This is hard because everyone's setup is a little different, but even the bare-bones configuration that I'm trying for starters  (just MobileSheets and Bome's Midi Translator Classic) doesn't work (for me).  Maybe someone could point me in the right direction....  When I turn my piano keyboard on  and hit a key, I can see Bome's Midi Translator log the key, so I have had some success with Bome.

As a test case, in one of my songs, I did "Edit Midi Command" and chose the following:
    Note On
    Input -> Any
    Output -> Any
    Command -> 25   

I opened Bome's Midi Translator Classic and chose the following in/outs:
    Midi In -> Bome Midi Translator
                   (the other choice is 2-Focusrite USB Midi)
    Midi Out-> same two choices

Next, I clicked on "Test Midi Connection" -> nothing;  the "midi in"  doesn't flicker.  Nothing on the log.

I went back and tried every combination of Input and Output in Mobilesheets, still no response in Bome
    Port B(0)
    Remote (1)
    Port A[2]
    Midi [3]
    2-Focusrite USB Midi[1]
    Bome Midi Translator


Bome Midi Translator and MobileSheets are both on the same PC, so I don't see why this doesn't work. Can anyone point me in the right direction?    Huh

Thanks!
Reply
#2
I am not very familiar with Bome's Midi Translator Classic, and I don't know whether it is creating virtual MIDI ports or if it's designed only to connect to MIDI accessories, but I would strongly advise trying to remove that from the equation until you've got things working with a more simplified connection. Bome may connect to the MIDI device and then prevent MobileSheets from connecting to it, unless you are connecting MobileSheets to Bome and it is using virtual MIDI ports to allow MIDI messages to flow through it. You haven't provided all the details, so I'm going to make the following assumptions:

1) You are running MobileSheets on a Windows device
2) You are connecting to your MIDI devices over USB
3) You have a Focusrite device between your Windows device and the keyboard
4) You have the MIDI keyboard set up to listen on either MIDI channel 1 or all MIDI channels
5) You have MobileSheets configured to not use multiple MIDI channels and it set to MIDI channel 1.

In that case, please do the following:

1) Go to Settings->MIDI Settings->Select MIDI Devices
2) Tap the input and output ports for 2-Focusrite USB Midi. You should see "Connected" listed after the name if the connection is successful
3) Go to the library screen, go to the Songs tab, tap "New" go to the MIDI tab, tap the + icon, and then set up a MIDI command that you know the keyboard will respond to. I would advise sending a Program Change message with a value of 2. This should switch to the 2nd instrument in the current bank on the keyboard.
4) Tap the Test MIDI Command button. The instrument should change on the keyboard if you used a program change message

Let me know if you are not able to get that working.

Mike
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.