• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Editing song black screen issue with trial

I downloaded the trial of this app this morning - for several years I've been using Adobe Reader Touch to play music from, and after less than an hour trialling this program I think it's amazing.

However I've been having an issue which I'm hoping someone can advise on, perhaps it's a known issue.  This happened first when I edited a song's properties to add a metronome mark - when I then clicked OK on the properties window, I got a completely black screen within the app.  I tried tapping everywhere etc but no response, only solution was to use the back button on the Windows title bar, which then closed the app.  I tried editing the same song again (but this time didn't edit any fields, just pressed OK) and the same thing happened, then I tried a different song and it saved OK, so I went back to the original song and it worked fine.  I then tried various songs editing various feels and it didn't re-occur.  A little while later when editing another song I pressed Cancel (rather than OK) while editing a song's properties and got the same issue - when I retried, it worked fine.

This also happened again just now when attempting to create a new song - I clicked New (rather than Import), selected file from disk, the app did it's auto-cropping, I pressed OK and got a black screen.  Interestingly when I used the back button on the Windows bar this time, it asked me if I wanted to save or discard my changes (so the new song hadn't saved at that point).  I pressed save, but still just a black screen.  When I used the back button again it then quit the app.  (When I reloaded the app, the new song was there).  It seems the app hasn't crashed when this happens, as the Windows back button works and it closes gracefully.

I tried looking on these forums but couldn't see anyone's reported an issue like this - my concern is it's happened 4 times already and I've only had the app installed a few hours.  Any suggestions? Please let me know if more info needed.

I'm using a Surface Pro 4 and running Windows 10 1903.


I definitely don't like the sound of that. It sounds like an error is being encountered in the code which is causing the code to stop processing when it's trying to exit the song editor. I'll try to add some additional error checks to see if I can prevent this. I definitely have not encountered the problem you are describing myself and I haven't heard from any other users that are encountering it, so it will be difficult to figure out exactly what's going on. If you are willing, it would be great if you can update Windows 10 to version 1909 (https://www.microsoft.com/en-us/software.../windows10, click "Update Now" to get the Microsoft Update assistant) to see if this issue disappears after updating. 1909 is a minor update, so I don't think it's going to fix the problem, but I'd like to rule that out as a possibility, as Microsoft often fixes things in the Windows framework that can impact UWP applications. I've heard reports of file browser issues with version 1903 that are resolved in 1909, for example.

Hi Mike

Thanks for the quick reply - when checking Windows version when writing the original post I was surprised to find my Surface was still running 1903.  I've now done the 1909 feature update but the problem persists.  I've been messing around for the last hour (or two now I think!) trying to find a way to consistently replicate it as it's seemingly inconsistent.  I managed to replicate the issue three times in a row using this method, but subsequently not consistently:

  1. Edit Song 1 - make a change (e.g. change the Tempos value) and click Cancel - click Save Changes when prompted.
  2. Edit Song 2 - don't make any changes, click Cancel and then Save Changes when prompted. (Variation: also happened when pressing OK at this stage, difference being Step 4 is skipped)
  3. Black screen.
  4. Use Windows back button - it asks you again whether you want to save changes. If you click yes you get an error in bottom right (overlaying black screen) saying something like 'you must add one or more pages'
  5. Use Windows back button - this time click Discard, and then click back again to exit the app.
  6. Re-open app.
  7. (Steps from here on happened twice in a row but not third time) Edit Song 1 - notice that in fields that had tags (Genre and Collection) the tags were now duplicated
  8. Click OK 
  9. Black screen.
  10. Click Windows back button - exits app.
  11. Re-open app.
  12. Edit Song 1 - tags reverted to one in each field (no longer duplicated)
Something I also noticed (may or may not be related) regarding the cancel button:
  1. Edit a song - click Cancel without making any changes - observe you're not prompted to Save as you made no changes.
  2. Edit a song - make some changes, click Cancel - you are prompted to Save - click Save Changes.
  3. Edit a song - click Cancel without making any changes - you are prompted to Save, even though you made no changes.
  4. Step 3 behaviour continues until app is restarted
Another thing which I think happens (hard to tell for sure) is when initially clicking "Edit", there seems to be an increased delay/small stutter when opening the Edit Song screen on the occasions where I subsequently get a black screen after clicking OK/Cancel.

I'll give things another go tomorrow and see if I can find any other ways to replicate it, but thought I would post all the above in case you notice something in amongst my comments which might hint at the cause of the issue.


Edit: added final comment about the Edit Song delay.
Thank you for all of the information. I'll work on tracking down the issue (and also fix the issue with it prompting you after canceling with no changes).

Hi Mike

I've been having another play this afternoon and think I might've spotted the issue.  Occasionally when pressing Edit Song there is a delay loading the Edit Song screen as I mentioned before; this seems particularly prone to happening when clicking Edit Song immediately after opening the app, or also after leaving the app idle for a while (say 30-60sec) then clicking Edit Song.  When this delay happens, if you wait (approx 2 sec) the Edit Song screen opens, but the temptation is to think your click didn't register so the natural reaction is to click Edit Song again after a second or so, since it usually opens immediately.  When you hit Edit twice (or even three times when nothing seems to happen after the 2nd click), when the Edit Song screen eventually opens, it's immediately obvious there's an issue on songs where you have tags (e.g Genre) as the tags appear more than once (on one occasion the Genre was in the list 6 times) and when this happens, hitting OK/Cancel will always cause a black screen.  If you're editing a song without any tag-like fields added, it's not obvious there's been an issue so you don't expect the black screen which subsequently happens when you click OK/Cancel.  I'm not sure if it's this one issue that was causing all the black screens I experienced yesterday, but it's quite possible since in the steps I listed above there was consistently a delay opening Song 2 after saving Song 1 - I hadn't realised but perhaps I was subconsciously clicking Edit twice during that delay.

In any case, I'm going ahead and purchasing the app, since I love all the features (I've played for several hours today in performance mode which is working flawlessly) and I want to get building my library now Big Grin  It's clear from these forums the support is excellent and you're keen to hear about and fix issues.

Let me know if I can provide any more info to help you pin-point this issue! Cheers.
That's very helpful - thank you for looking into that and reporting it. What you've described makes a lot of sense - if the code tried to open the edit screen while it was already open, it would do some interesting things (none of them good). I will see what I can do to prevent the delay you were describing or at least make it more obvious that processing is occurring and the edit screen is being loaded. I'll also add code to prevent the edit dialog from being triggered twice.

Thanks for buying the app and helping me track this down!


Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.