• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Small problems with Surface Go 2
I've been using MobileSheets for a few weeks now to read choral music on my Surface Go 2. For the most part, it's really impressive software and works very well. I've got the Surface model with a faster processor (m3) so it is generally quick and responsive. But I've found a few small problems.

Page Turns:
It seems like page turns aren't very reliable. I'm using purely touch interface, either tapping the sides of the screen or swipe gestures. If I try to test this and turn a bunch of pages, it always seems to work well. But when actually reading music where I'm flipping pages once or twice a minute, many times it doesn't work.

It's entirely possible that page turns while sight-reading difficult music might be distracting enough that I'm not doing nice clean taps and gestures. I understand that if the swipe isn't long enough or goes a bit crooked, it's not registered, or if I tap but slide a bit, it doesn't count as a tap. But even when I'm being careful it doesn't always seem to work. I can also usually see that Windows has registered the taps because it draws a small circle where I tapped.

Three Finger Tap:
I have the three-finger tap gesture set to open Annotation mode, but it seems like even when being careful, this only works abou 70% of the time. 20% of the time nothing happens, and 10% of the time, it just brings up the header and footer (like a one-finger tap). Again, I could be making sloppy gestures sometimes, but generally Windows draws three circles where I'm tapping, so I'm sure Windows is detecting the three taps.

Also, most times when hitting Cancel to leave annotation mode, it goes straight back to full-screen reading mode, but occasionally it shows the header and footer, so I need to tap again to go back to full-screen.

Drawing with Pen:
I also have a Surface pen for drawing annotations using the Pen tool. While drawing, every few seconds the line stops updating for a second, and when it starts again, it misses all the movement that happened in between.

When using it normally to make small annotations, is just seems like some of the lines or letters I draw get skipped, but I can test it by just drawing circles continuously, and it's clear that about every 5-6 seconds, it just freezes and stops recording the pen input for about a second.

I've used several other pen drawing apps (Sketchable, SketchBook, Concepts), and never noticed this behaviour in any of them. I have no other programs running, and I can't see any spikes in processor usage in the Task Manager.

There are some other quirks with annotations, but I read that this is currently being overhauled, so I can wait to see how the new system works.

Anyway, I can investigate the issues further or capture recordings of some of these problems, if that would be helpful.
Mike is working on updating the annotation part of the program right now. So, I would ask to get on the Beta version and give it a go to see if the new version will help your situation.
To avoid misunderstandings: The Beta for Win10 isn't available for testing yet, only the Android version.
I'm happy to try the Windows beta when it's available, and I signed up in that thread. 

But the first two issues happen outside of annotation mode and don't seem likely related to that work. I'm curious if anyone else has problems with gestures being recognized.
I can investigate the issues you are encountering with gestures. I don't recall seeing issues on my Surface Pro 4, but I can run through a series of tests to verify that is still the case.

I did some more testing recently.

Relating to the page turn taps:
This time I noticed that the times when tapping failed to turn the page, the windows circle did not appear. I was certain that I tapped as firmly as I ever do and it should have been registered but it seemed like Windows itself didn't detect the tap. I thought it could be that the device goes into power-save mode after some time, so I tried setting the power profile to "Best Performance", but it didn't seem to make a difference.

Relating to two/three finger taps to change modes:
I tried remapping the taps to different functions besides switching to annotations mode, and regardless of what function is set, the taps are not recognized consistently. Both two or three finger taps seem to work correctly about 50% of the time.

Relating to annotations with the pen (I realize this can wait until the beta test, but the information is here):
The same problem happens (it stops drawing lines every 5-6 seconds) with either the pen or with a finger, so it doesn't seem to be related to the pen itself.

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.