• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Import cannot find USB drive
I have two ancient Hanspree 13" Android tablets, one RCA / Pro-12 12" Android tablet with detachable keyboard, and an HP X360 14a Chromebook. All run MobileSheets 3.3.6 from Google Play (except the Hanspree that cannot connect to the Play Store at all).

On both Hansprees, after connecting the USB drive to the OTG connector (via adapter), clicking Import/LocalFile shows it (Root/mnt/usb_storage). All is well.

On the HP Chromebook, after plugging the USB drive into the USB-A port, clicking Import/LocalFile shows it. All is well.

But on the RCA, after plugging the drive into its USB-A connector, or via adapter into its OTG connector, Import/LocalFile does not show the USB drive, and I cannot find it anywhere. I can click on .../SetSDCard, click OK on the instructions, and select the USB drive (which shows its files) -- but I still cannot find it in the MobileSheets SelectFiles dialog. It's not in Root/mnt/* or Root/sdcard/* or Root/storage/*. Doing a search from Root for "usb" finds nothing; nor does a search for a word in one of the filenames on it.

I would like to use a USB thumb drive to import files, so I have a single workflow for all tablets. Is there anything else to try?

This is weird -- the Android FileManager App does not see the USB drive either. But Android's Settings/Storage&USB does see it; MobileSheets' SetSDCard does see it to select, but not import.

There are differences between SD cards and also probably support by the different operating systems and how the device has been formatted.

Suggest you save all the files on the card to another device (so that you can restore them later) and reformat the thumb drive in the RCA.
Having reformatted, try using it for normal file operations i.e. not using MSP
If that doesn't work you need an alternate thumb drive.

If it does work, try using native copy operations on your other devices.
Assuming that works, delete your test files and restore the files you copied off before formatting; then test using MSP

Samsung Galaxy Tab A6
This is not an SD card, it is a USB thumb drive.

I formatted a different USB thumb drive on the RCA. My Mac says it is formatted "MS-DOS (FAT32)", just like the other one. I put a file onto it. It behaves exactly the same as I described in my original post -- no joy.

Since the Android File Manager app does not see the USB drive, I don't know how to copy files from it to some place where MSP could see them.

I have a USB adapter for an SD card. I put my files from my Mac onto an SD card and then plugged it into the RCA -- MSP could import just fine from it. I then plugged it into a Hanspree tablet, and MSP failed to find it (just like the USB drive  in my original post). Putting the SDcard into the USB adapter and plugging that into the Hanspree OTG worked. Both tablets run MSP 3.3.7 from the Play Store.

So it looks like my hopes of a single workflow for all tablets fails. USB thumb drive is close, SD card with USB adapter is close, Companion app is close, but no success for any of them on all tablets.
In the future I'll probably use the SD card with USB adapter, as that's easier than jumping through the hoops required to use the Companion App on the HP 2-in-1 Chromebook.
Sounds as though you need to go down the "Sync Library" root using wifi  (I've never used it)

Samsung Galaxy Tab A6
have you tried a different file manager, eg.: es file explorer or total commander?
Dell Latitude 13.5" 2-in-1 Ubuntu/Win 11
Samsung Note Pro SM-P900 12.2 Android 5.0.2
Samsung S7+, Android 12
Hallo ,
dieses Problehm scheint nicht lösbar zu sein habe mit der Firma Samsung ca. 1 Std.telefonsch nach einer Lösung des Problems gesucht, ohne Erfolg. Bei einem Gerät funktioniet es bei einem Anderen nicht.
Siehe auch mein Thema vom 10.06 2021

Thema gestartet von diamant-ct
Gruß Achim!

Hi there ,
This problem does not seem to be solvable. I tried to find a solution to the problem with Samsung for about 1 hour, without success. With one device it doesn't work with another.
See also my topic from June 10th, 2021

Backup difficulties
Topic started by diamant-ct
Greetings Achim!
If you use Import->System File Browser, you should be able to use either Google's file picker or an external application (depending on what Android OS version that tablet is running). Google's file picker should detect your USB drive and allow you to import from it. Have you tried this yet?

Otherwise, if you used Import->Local File, you would need to know the path to your USB storage. On lower Android versions, this would usually show up under /storage under a mount point (a character hexadecimal name such as F325-B24A), but on newer Android versions, you can't access /storage anymore, so if you tap the storage icon in the top right corner of the MobileSheetsPro file browser and you don't see an entry for the removable storage in the dropdown list that is shown, then MobileSheetsPro probably won't be able to access it. 

I have never used SyncLibrary and tried it, using a Hanspree tablet as the server, copying to the RCA tablet. It took over two hours to compare 1458 pieces, but ended successfully. I'm rather surprised and disappointed that it went so slowly, as they started >99% the same. A second SyncLibrary (they are now 100% identical) did not go much faster, and found a bunch of duplicates, each of which I had to select manually. I had hoped this would be an efficient way to add a few songs -- add them to one tablet and SyncLibrary to the others.

My HP Chromebook had a thousand duplicate songs, due to problems connecting to the Companion app. So I cleared its library and did SyncLibrary from the same Hanspree. It succeeded, going almost twice as fast.

That's pretty slow just to add a handful of songs, so I'll probably use an SD card and the USB adapter. (That's better than the Companion app, as I must run it in a Windows Virtual Machine on my Mac.)

I didn't sync up my second Hanspree tablet, because it just died some more -- its touch screen stops responding a minute or so after waking it up Sad . This one is noticeably slower than the others, it cannot connect to the Google Play Store (for updates), and its battery now lasts less than a half hour. Since I now have three other tablets I'll probably give up on it and recycle it.
(01-05-2022, 06:42 AM)Zubersoft Wrote: If you use Import->System File Browser, [...]

That works on the RCA, and I can import from a USB thumb drive. Unfortunately it is only one file at a time. Batch Import cannot find the USB drive.

Otherwise, if you used Import->Local File, [...]

That does not work, in any variation you suggested.

The Google File Picker should be able to select multiple files - you just have to long press to start the multi-file selection I believe.

Thanks to all who responded, I now have learned about features in MobileSheets Pro that I did not know existed. They have improved my workflow considerably.

I decided there were too many duplicates, which I had been living with for months, so I decided to bite the bullet and start completely over. My primary music source is on my Mac, and it's backed up in five geographically diverse places. Due to the way its filesystem works, there can be no duplicates there. The music that goes onto my music display totals 5GB, which I copied onto a USB hard drive. I plugged the drive into my HP x360 14a Chromebook, cleared its database in MSP, and did 12 BatchImports of 1427 pieces in 12 folders (which map to Genres in MSP). Checks of Genres and songs looked fine. I then used SyncLibrary to transfer that music library to the other two tablets (after clearing their libraries). Due to the limits on networking on the Chromebook, I made the other tablet be the server and the Chromebook be the client, syncing Client->Server. This all went without a hitch, and tests showed the music was there correctly.

This went an order of magnitude faster than my old method using the Companion app running in a Windows virtual machine on my Mac. I update the tablets every few weeks with a handful of new songs. I'll put them onto a USB thumb drive and use Import/SystemFileBrowser to import them (thanks Mike!). So it looks like I may not need the Companion app at all -- I'll keep it just in case....

Again, thanks to all who responded. This community is great!
über: "Importieren->System-Dateimanager" kann ich auf den
USB-Stick zugreifen.
Vielen Dank für den aufgezeigten Weg auf den USB-Stick zuzugreifen.
Gruß Achim!

Hi there,
via: "Import-> System File Manager" I can access the
Access USB stick.
Thank you for the shown way to access the USB stick.
Greetings Achim!

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.