• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Changing the home directory
#11
Yeah, my bad feelings about this were warranted. I tried to move it, didn't consider that I also moved the place of the database (since I solved that with a junction from my dropbox folder to the users dir which worked fine), so I restored that.

But the change of the storage place didn't worked. So I moved it all back to the old place in my dropbox. But now when I start up MSP doesn't recognize the old storage dir any more (though it is accessible and there) and I get the message (W10 BTW)

Storage location inaccessible (etc.) with the three options 

continue waiting
change storage location to default
quit MSP

And - I think that's a flaw - you can't got to the settings and change anything when you go back to the MSP GUI from that screen.

Help, please?
Reply
#12
Is this with the Android version? If so, send me an email at mike@zubersoft.com and I'll hook you up with the latest build which will eliminate that check at startup. 

If it's with Windows 10 (which I'm assuming it based upon your previous post), then it's pretty important for access to be available to the storage location. The problem is that, if you select a folder, delete that folder, then recreate that folder, the token that MobileSheets has stored to that previous folder instance may no longer be valid (I don't know how Microsoft handles this internally).  Can you restore the previous folder instance from your recycle bin? There isn't a way for me to regain access to the new folder instance without bringing up a file browser for the user to select the folder instance again (that's how Microsoft requires the user to grant access). I think I'll modify that check at startup so that it gives you an option to select the storage location to grant access to it.

Mike
Reply
#13
Yes it's Windows. And no, I don't think I can restore the previous instance from the recycle bin. I actually didn't delete (since I'm overcautious with the loss of my files) but renamed it and created a folder with no
content in the same place.

Well, after that I got the message I described and I now chose to restore the folder in the default location so I thought I could move it from there again which I tried or rather I'm trying (and it's trying).
After the usual warning it started to move files sloooooooowly. At least it's saying it's moving files to the new storage location (where all files are already present). I'm still not sure what MSP is trying to right now. It's still only at 4 % after 2 hours (and haven't moved from 4 % for the last 50 minutes or so).

Well, I'll leave it overnight now and look at it at tomorrow again. But maybe I'm better of with using a backup copy of my database and my files and reinstall the whole thing.
Reply
#14
I'm sorry this has been such a painful process. I'll do what I can to make it easier to resolve these kinds of issues in the future. 

Thanks,
Mike
Reply
#15
Thanks. FYI MSP is still stuck at 4 % of moving the files after the night. I canceled it now and have to see what I can salvage.
Reply
#16
A really interesting thing happened.

After I tried the change storage location process once again the day before yesterday, still on 2.4.9 on W10, and let it work through the night again the progress bar again was still stuck (this time on 0 %) when I looked the next morning. Sso I canceled again (like before).

When I started MSP (still on 2.4.9 W10) today on my desktop the new storage location was in the settings and the files were found.

I'm happy with the result but how it got there especially with the moving and no progress bar is a bit confusing to me.

I have to test if all is in the right place but it seems so for now.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.