• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Restoring Backup stays at 100%
Hello everyone,

I've got a problem with restoring a backup of my library. 
It will run according to plan until song 4986 of 4987. At that point nothing will happen. No error message or anything.
I have tried to restore my backup three times now and the problem stays the same.
I waited for over an hour for the last two files to finish, but still nothing happens.

I am using Windows 10 with the most recent versions of the app and companion pro.
Can this be a problem with the large .msb file (around 5gb)? Is there a way to try the backup without companion and directly via the app? I guess it won't be possible to copy the 5gb backup file onto my FAT32 SD-card, as there is a 4gb file size limit on it, right? Restore does not work via cloud, does it? Are there any other options?

If I abort the process, I can see my library, but the links to the .pdf and .png files don't seem to work properly. I get a message that the file is not found at the expected file path.

Any help would be greatly appreciated! How do you guys deal with >4gb backup files and how do you restore them? Any experience on that?
I have never tested with a backup file that large. I think the largest I've tested with is about 3.5 GB. Can you view the backup under File->View/Extract Backup? I just want to make sure the companion is capable of reading all of the data correctly. It sounds like what may be happening is that most of the files are being transferred (or the companion thinks it's transferred them) but the tablet is getting hung up on something and never finishing. Out of curiousity, how much space do you have available on the tablet? You are correct about the 4 GB file size limit on Android. I haven't yet devised a way to split up backup files into several parts so that a backup can be made and restored on the tablet if the total size is over 4GB. That's on my list of things to do.

The backup restore does work off the cloud, but it's implemented in such a way that it first must copy the backup file to the tablet before extracting it. Only the companion app is designed to stream the data back and forth with the tablet app. I think we are going to need to figure out what is going on so that you can properly restore that backup file. I may need to work on generating a 5GB backup file so I can test the same way you are. It may take me awhile to put that together though as the directories storing all of my scores only amounts to 3.96GB.

Hey Mike,

thanks for the quick reply!
Reading the backup file with extract/view does not seem to work. I have waited for 45 minutes without success. It shouldn't take so long, right?

I let the restore process run for the whole night, expecting to get some kind of a message, but still nothing happened after 7-8 hours.
I then cancelled the process in the companion and my files seemed to be there this time. I will have to double-check more of the files to be sure everything's in place, though.

I am trying to restore the backup of my tablet library to my smartphone just to be sure it works out in case of emergency, as I read that there is not much experience with files that big.
The phone has 3gb internal storage available plus a 16gb sd card with 15gb available (that's where the data is going), so it should be all fine.

(02-12-2016, 05:59 PM)Zuberman Wrote: I may need to work on generating a 5GB backup file so I can test the same way you are. It may take me awhile to put that together.....


br03tch3n has one - why not ask if you can use that?

1: Samsung 12.2" SM-P900: Android 5.0.2 
2: eSTAR GRAND HD Quad-Core 4G 10.2": Android 5.1 
3: Home-built BT pedal

Some of my music here
br03tch3n, any chance you can upload that backup file to something like Dropbox so I can access it? It would certainly save a ton of time. If not, I'll have to see what I can manage when time allows.

My backup file is 10.5GB, backup works nicely when it is generated on the "hard disc" of the tablet. Copying the file afterwards to PC is not a problem, from there I copy it to another tablet and restore the library on that other tablet. Saving the file on the tablet's SD doesn't seem to work, neither a backup through companion. Of course, the tablet must have 2x the capacity of the backup file. I immediately delete the backup file after restore, to give the tablet some slack again. It would be fantastic to be able to use the SD card though I haven't tried hard enough (reformat SD card?).
"view the backup under File->View/Extract Backup"...
This works with the mentioned 10GB file.
Ben, that is weird. I can't view my backup in companion at all. Have you created the backup on the tablet or via companion? Maybe I'll try to backup everything on the tablet to make it work. Your method surely works, I also found out that there is no file size limit on the internal drive of my tablet.
Mike, I have uploaded my backup file on my Google Drive and sent you the link via PN. I hope you can figure something out with it!

Edit: I have created another full backup via the Android App. This time it can be read via "view/extract backup" and restored to my mobile device using the companion app. There must be some difference between the app and the companion backup process.

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.