• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Esraser creates
Hello all   (as Newbie on this forum),

I have a strange experience with Mobilesheets.
During rehersals I make my notes quickly on the annotation screen, and later on I try to clean up and make it more 'readable'. (txt instead of rough writing etc.)

When I remove such a note with the "eraser tool" it dissapears, but it creates (1 or 2) new long new long lines in return. (vertical or horizontal)
The Undo solves it, but many retries does not help. Sometimes I manage to clear partial of the bad note (without extra lines), and a small point or line alwys remains.

It does not happen at every removal, but TOO often!     Angry  

Please Help. Roelof
Hello Roelof,

I have a couple of questions. First, with the eraser tool, it's designed so that you draw a box around what you want to erase. Are you doing that or are you just tapping where you want to erase? Second, to remove a free form drawing, you must draw the eraser box around the whole thing, otherwise it will only erase the part inside the box. Are you deleting the whole drawing?

Another way to delete is to use the list on the left side. This can be enabled by tapping the circle at the top left. You can tap the trash can icon at the bottom right of the list to delete any of the currently selected annotations.

Let me know if you have any questions about this.

Hi Mike,
Thanks for quick response and the work you do on MSP.

Yes, I draw a rectangle box around the to be erased area.
Yes, correct I tried to erase the handwritten notation as a whole.

I tried to add a screenshot but the forum is having problemns with accepting the size.
When I tap the circle there is no trash can visible. (starts wtih Show list etc)


If you tap Show List and select the pointer tool, you can then view all annotations that have been created. From there, you can select and delete them as I described. As for the issues with using the eraser, please let me know if you can find a way to easily reproduce the problem. I can't seem to replicate the problem yet.

Hi Mike... First off, thank you very much for your hard work. MSP seems to be a very fine program, and so far (had it for a few days) it's working quite well for me. There are a few small niggles, though. One of which is the above mentioned problem with the eraser... I experience the exact same problem as Roelof. It seems that the eraser makes those line shapes by extending single dots positioned across it's path. Deleting via the list works as expected, but it would be great to be able to simply erase, without having to open the list. (Actually, it would be awesome to have an eraser that does not require a box at all, but simply erases where ever you use it.) I use MSP almost exclusively for HAND WRITING charts, so there are quite a few dots all over the page (repeat signs, etc...), which make this is a fairly annoying bug for me.

I have included links to 4 images, showing what's going on. Maybe you're able to replicate the issue, and provide a solution with an upcoming update to MSP...

Pic 01 - My initial test set up including handwritten text, 3 dots, and a wiggly line (to be erased)
Pic 02 - Drawing the eraser box
Pic 03 - The 3 dots have been "pulled" toward the eraser box, once I let go of the eraser
Pic 04 - Undo fixes the dots, but also brings the erased item back


I just experienced this same issue yesterday in rehearsal. Didn't think to take a screenshot, should have.

I was erasing some highlighting by drawing the box around the area to erase. After erasing, there was suddenly two parallel straight lines down my page with a red pen (probably red because that's my default pen color?). Also, a portion of the music got covered by a new white-filled box (that's how I like to "white-out" my music, a white rectangle with white borders and white fill)

This did not correspond with the area I was erasing, seemed completely random. Upon undoing and retrying several times, it appeared that the stray new lines were in exactly the same place every time, regardless of where I tried to erase.

The only solution I found was to let it draw the extra lines and white fill, and then use the eraser again to remove the new noise. The second erase in this process did not generate any more noise.

If it happens again, I'll take a screenshot...but I won't be using it again until Saturday this week.
SmarTab StreaMachine 13.3", Android 4.4.4
Samsung Galaxy Book 12, Windows 10
Samsung Note 20 Ultra 5G, Android 11
AirTurn PED
There is a problem involving dots, as demonstrated in the images provided by Casual-T (thanks!). I have a fix in place now that will be included with version 1.3.7 which I'm aiming to release tomorrow morning. There is a similar issue that can affect rectangles, so that will be fixed as well.

Sounds great... Looking forward to giving the new release a whirl. Thanks much, Mike!!
Update 1.3.7 FIXED this issue... Pretty awesome. Thanks, Mike!!
Glad to hear it, thanks for helping me locate the problem.

Users browsing this thread:
1 Guest(s)

  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2024 MyBB Group.