• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Annotations with stylus: Button tool and invisible layers
#1
Hi,
it's been quite a time since I had a whish or problem to post here, but using the new annotation mode with my MS pen on my new Surface 8, I have two annoying little problems, which could (hopefully) be solved easily:

1. Button to change tool
In the annotation settings, you offer to change the tool using the pen's button. Great, but it would be even more useful if it would change back to the last tool if I press the button again, especially considering the preselected selection tool.

2. Draw in actively shown layer by default
It seems that annotations still often go to an invisible layer. I remember there might have been an update about this, but I'm not sure...? I mostly use the layers to make different annotations on the same piece if it is played in different bands, so normally only one layer is shown (which is how it worked before the big annotation update anyway, I even use a touch zone to skip through the layers quickly). I'm not sure if it makes sense to add annotations to an invisible layer, anyway, so I'd expect/suggest something like:
  • if there is only one layer visible, add new annotation to this layer + activate it automatically
  • if there are more than one layer visible but none is active, add to + activate the layer which was edited the last time
  • if there is no layer visible, give out a warning and don't accept new annotations


What do you think? Or is there even something like this implemented already and just does not work as it should on my machine?
Reply
#2
1. I'm a little confused by what you have wrote. The stylus tool button setting temporarily switches the tool if you draw while the button is pressed, but then it immediately switches back to the previous tool once you pull the stylus up. It does not switch tools and leave it switched. I just tested this on my Surface Pro 4 and it works exactly as I've described. For example, if the stylus button tool is set to stamp, I can hold the button, place a stamp and when I release, it switches back to the pen tool.

2. A layer will always be active, so if there is only one layer, that one will be selected, otherwise it defaults to making the first layer active. If there is no layer visible, the application does present a warning now (a bubble pops up at the bottom of the screen). The annotation is still created though - I was torn on whether to allow the annotation or not in this scenario. I do not persist what the last active layer was when the application was closed. I can certainly consider saving that if it's really important to users, but it seems to be simple enough to switch the active layer in the layers window especially as you can switch the active layer for all pages at once. 

Mike
Reply
#3
Hi Mike,
Thank you for your fast response! 

1. OK, I experimented a little more and now I understand: I had not yet choosen a secondary tool at all. In that case it defaults to the selection tool (which cannot be chosen afterwards) and stays there if I select anything with it. So if it should work as you described, it should not do anything (= stay in the same tool, not change to selection) until a secondary tool is selected, should it?

2. OK, I'll describe my current useage case a little more in detail: I'm rehearsing a piece in a band, that I rehearsed in another band before. So I added a new layer to all pages and use this one (layer 2) mostly these days. Of course I use layer 2 now as the only visible one (I made a mark on each page in the layers to make sure I have the right one while I'm playing from it, too). Now I take my stylus and make a note and ... it's gone as soon as I release the stylus.
The annotations are made on layer 1 (which is invisible) by default... well I know this now, so I'm not as confused anymore as I was when it happened the first time, I bring up the layers window, change the active layer and go on, but these seem unnecessary steps for me: There is only the second layer visible, so it seems natural that additional annotations should go to this layer, doesn't it?
Reply
#4
I think if that button is not assigned to anything and you press it, it's the equivalent of a right-click. The Windows 10 version of MobileSheets switches to the selection tool if you right-click, so that's why you are seeing that behavior.

I can update the code to use the first visibile layer as the active layer instead of defaulting to the first layer in the list. That does make more sense.

Thanks,
Mike
Reply
#5
Sounds reasonable, thank you for considering my suggestion!

BTW, I'm on a Surface pro 8 and therefore Win 11 now, but concerning MSP, everything seems to work as before without any problems as far as I can see. Just another hint that you did your job thoroughly! Smile
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2022 MyBB Group.